Fordmods Logo

EA having serious fuel problems... 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: EA having serious fuel problems...
Posted: Tue Jun 12, 2012 10:23 am 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 135

Joined: 31st Oct 2008

Gallery: 5 images

Ride: EA Falcon S pack now 4.0l

Location: Tweed Heads
NSW, Australia

hey guys need some help on fuel system i am running an ef motor with LOG manifold and EA ecu when we first put motor in seemed fine but lately it has been spitting and spluttering really badly sounds horrible and also sounds like it isnt firing properly so im not sure if it is the fuel pump going as it makes noise for a while on ignition but it seems to almost feel like its running on 5 cylinders. ive changed injectors as well made no difference it really does feel like it is getting a lack of fuel. could it be pump? or could it just be ignition problems or manifold problems im really not sure. any help would be appreciated thank you.

Michael

 

_________________

1990 ea ford falcon getting ready for boost.

2000 Ford Courier 2.5l Turbo Diesel

YZ250 2009

Top
 Profile  
 
 
 Post subject: Re: EA having serious fuel problems...
Posted: Tue Jun 12, 2012 2:48 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

when was the last time fuel filter was changed?

A really blocked fuel filter can cause spluttering issues. Had that problem with my EL when I first bought it and when I took the fuel filter off, I could barely blow through it.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: EA having serious fuel problems...
Posted: Tue Jun 12, 2012 3:01 pm 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

it could also be the fuel pump, when mine died it slowly got louder and rattled in the tank and the car would wind and wind and wind for ages and then start on a few cyinders and finally it would run. when the fuel pump died and i replaced it the funny starting issue went away and the pump was quiet

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: EA having serious fuel problems...
Posted: Wed Jun 13, 2012 9:47 am 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 135

Joined: 31st Oct 2008

Gallery: 5 images

Ride: EA Falcon S pack now 4.0l

Location: Tweed Heads
NSW, Australia

cheers lads im gonna take out the filter today and check that as i found out it hasnt been done since it was last serviced like 10 years ago..

michael.

 

_________________

1990 ea ford falcon getting ready for boost.

2000 Ford Courier 2.5l Turbo Diesel

YZ250 2009

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 7:32 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names