Fordmods Logo

EF ECU overheat sensor 


Page 1 of 1 [ 2 posts ] 

 Post subject: EF ECU overheat sensor
Posted: Wed Sep 25, 2013 5:26 pm 
Fordmods Newbie

Age: 29

Posts: 4

Joined: 25th Sep 2013

Ride: EB Fairmont ghia 5lt

Location: Adelaide
SA, Australia

I am currently having problems with my EF, I was driving and didn't realise that the radiator cap had popped up for some reason, Probably due to me not putting it on properly the day before, and had lost all water, I didn't notice the temp and all of a sudden the motor just died, I filled the radiator with water and it has been almost 2 hours but the sensor has not switched off, as it is as cold as it is going to get and as soon as I turn the ignition on the thermo's start up and the temp warning light is still on, I have tried resetting the ECU but I have gotten as far as reconnecting the battery, because it still wont start. Any help on this issue would be most appreciated
 Post subject: Re: EF ECU overheat sensor
Posted: Wed Sep 25, 2013 5:35 pm 
Technical Contributor

Age: 59

Posts: 6743

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Try replacing your temp sensor, you may have fried it.




South West Customs

Members of the SWC Stable, fordebgt93, TROYMAN, Benj, svo_matt, Mrs C, eb_fairmont, Total_tool, Terroristghia

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: MSNbot Media and 7 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 1:00 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names