Fordmods Logo

EF ECU overheat sensor 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: EF ECU overheat sensor
Posted: Wed Sep 25, 2013 5:26 pm 
Fordmods Newbie
Offline

Age: 30

Posts: 4

Joined: 25th Sep 2013

Ride: EB Fairmont ghia 5lt

Location: Adelaide
SA, Australia

Hi,
I am currently having problems with my EF, I was driving and didn't realise that the radiator cap had popped up for some reason, Probably due to me not putting it on properly the day before, and had lost all water, I didn't notice the temp and all of a sudden the motor just died, I filled the radiator with water and it has been almost 2 hours but the sensor has not switched off, as it is as cold as it is going to get and as soon as I turn the ignition on the thermo's start up and the temp warning light is still on, I have tried resetting the ECU but I have gotten as far as reconnecting the battery, because it still wont start. Any help on this issue would be most appreciated
Top
 Profile  
 
 
 Post subject: Re: EF ECU overheat sensor
Posted: Wed Sep 25, 2013 5:35 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Try replacing your temp sensor, you may have fried it.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:01 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names