Fordmods Logo

EF ECU problems 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EF ECU problems
Posted: Sun Oct 28, 2012 7:31 pm 
Fordmods Newbie
Offline

Age: 54

Posts: 5

Joined: 23rd Jan 2011

Ride: Ford Fairlane

Location: Ballarat
VIC, Australia

I does need some help me thinks. I've got abit of a weird problem here and need to know if an ECU needs to be properly attached in it's cradle to work or would just earthing them through their earth wire stop them from working right.

I've installed an engine/gearbox, ECU and wiring harness out of an EF Falcon sedan into a ZL Fairlane. I'm 99% sure everything is wired in properly as everything seems to be working OK except the motor won't run as I've discovered the injectors don't seem to be operating. I know it will start and run as at the time of doing the following, I had got p****d off bigtime with the whole show and was hopping to blow the thing up, so I poured some fuel straight down the intake and then hit the starter and to my surprise it ran for about 4 seconds until it used what fuel was in the intake.
I know the fuel pump is working OK and is pumping fuel past the injectors and they are getting power from the relay as I've also checked all that too, so from what I can see the part of the ecu that operates the injectors just isn't working and I'm wondering if it's because the ECU's not in it's cradle but only earthed by it's earth wire be the reason or is it a stuffed ECU or is there another reason. The ECU was in the car I took the engine and harness out of, but I never heard the engine running as the gearbox was off at the time, so don't know if the ecu was buggered right from the start or not.

I said it was a weird problem and any and all help in fixing the problem will be greatly appreciated.

Charlie
Top
 Profile  
 
 
 Post subject: Re: EF ECU problems
Posted: Sun Oct 28, 2012 9:00 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

As long as the ECU is earthed it will be fine. Did you fit the smartlock (BCM)? Smartlock shuts down the injector signal. Are you getting a pulse signal to the injectors?
Top
 Profile  
 
 
 Post subject: Re: EF ECU problems
Posted: Sun Oct 28, 2012 10:05 pm 
Fordmods Newbie
Offline

Age: 54

Posts: 5

Joined: 23rd Jan 2011

Ride: Ford Fairlane

Location: Ballarat
VIC, Australia

I was wondering about that as no, didn't fit the BCM. Is there a way to by-pass it to make the injectors pulse as I'd say that that is the problem for the injectors not firing.
Top
 Profile  
 
 
 Post subject: Re: EF ECU problems
Posted: Mon Oct 29, 2012 1:54 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 993

Joined: 26th Sep 2007

Gallery: 4 images

Ride: EL Fairmont Ghia

Location: Brisbane
QLD, Australia

if your not running the factory ignition barrel and bcm, it won't start. Best thing to do is just get a J3 chip to disable smartlock.

 

_________________

ED Fairmont Barra 190rwkw 4.10 Gears 3500 Stall 1/4 to come

Top
 Profile  
 
 
 Post subject: Re: EF ECU problems
Posted: Mon Oct 29, 2012 6:05 am 
Getting Side Ways
Offline
User avatar

Age: 44

Posts: 3805

Joined: 22nd Apr 2007

Gallery: 5 images

Ride: DENTED UP OLD AUT WAGON

Location: Wellington
New Zealand

Top
 Profile  
 
 
 Post subject: Re: EF ECU problems
Posted: Mon Oct 29, 2012 9:53 am 
Fordmods Newbie
Offline

Age: 54

Posts: 5

Joined: 23rd Jan 2011

Ride: Ford Fairlane

Location: Ballarat
VIC, Australia

Thanks guys, your help is worth your weight in gold.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 10:02 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names