Fordmods Logo

EF FAIRMONT HELP 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: EF FAIRMONT HELP
Posted: Thu Mar 22, 2012 12:59 pm 
Fordmods Newbie
Offline

Posts: 8

Joined: 13th Mar 2012

Ride: EF FAIRMONT TICKFORD OPTIONS

Location: nEWCASTLE
NSW, Australia

Hi Guys been having this drama for awhile now can't seem to nail it. replaced fuel pump fuel filter etc before working out it happens at low fuel levels.

When ever the fuel gets low (basically just under 100kmsleft/fuel light comes on) and we go around a roundabout and straighten up the car will lose all power and just about stall (like its ran out of fuel) keep your foot off the throttle for about 10 secs and the car raors back to life, the car does not play up while driving on a straight road.


I know the easiest solution is keep the tank full, which i try to do but its the Mrs's car and everytime i jump in it the fuel light is just about to come on.

What do you think maybe the problem, who else has experienced it and what have you done?
Top
 Profile  
 
 
 Post subject: Re: EF FAIRMONT HELP
Posted: Mon Mar 26, 2012 1:35 am 
Getting Side Ways
Offline
User avatar

Age: 25

Posts: 4599

Joined: 30th Aug 2010

Ride: BF XR6,

Location: NEWCASTLE
NSW, Australia

youv answered your own question, keep fuel in the tank lol.
one of my fairmonts used to do it aswell,

 

_________________

BF XR6
xr8 snorkel,typhoon lower snorkel,territory intake pipe,20% underdrive kit,pacemaker extractors,high flow cat,xforce exhaust,t56 conversion hd turbo clutch/ flywheel,m86 3.45 lsd,custom tune187.1rwkw as an auto

Top
 Profile  
 
 
 Post subject: Re: EF FAIRMONT HELP
Posted: Mon Mar 26, 2012 9:58 am 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

I'll say that it's eithier a fuel tank venting issue, or the sock filter on your fuel pump is stuffed.

Gab
Top
 Profile  
 
 
 Post subject: Re: EF FAIRMONT HELP
Posted: Mon Mar 26, 2012 12:41 pm 
Fordmods Newbie
Offline

Posts: 8

Joined: 13th Mar 2012

Ride: EF FAIRMONT TICKFORD OPTIONS

Location: nEWCASTLE
NSW, Australia

uniacidz wrote:


Thanks for your reply, I'll take a look at it.
I have replaced the fuel pump but we were having issues prior to that..... maybe the old pump was faulty as suspected, and have devloped this new issue since replacing it.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 7:07 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names