Fordmods Logo

el cluster problem's 

 

Page 1 of 1 [ 8 posts ] 

 
 Post subject: el cluster problem's
Posted: Tue Aug 17, 2010 12:40 am 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 122

Joined: 19th Nov 2009

Gallery: 2 images

Ride: 1994 ED XR6, 2003 BA XR8

Location: Traralgon South
VIC, Australia

hi all, i have recently bought an el fairmont cluster for my el dash conversion. i have previousley made an adapter loom from an ef cluster i borrowed off a friend that works fine on that cluster but when i plug it into the el cluster it doesn't work at all except for the illumination lights.
so i was wondering if the ef and el cluster wiring looms are different at all or did i get ripped off

cheers,
Tomo

 

_________________

98%of city drivers will say ''holly s**t'' befor going into a ditch in a snowstorm and 98%of country drivers will say ''hold my beer and watch this''

Top
 Profile  
 
 
 Post subject: Re: el cluster problem's
Posted: Tue Aug 17, 2010 7:31 pm 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 122

Joined: 19th Nov 2009

Gallery: 2 images

Ride: 1994 ED XR6, 2003 BA XR8

Location: Traralgon South
VIC, Australia

definately a fairmont cluster

Attachment:
el fairmont cluster.jpg
el fairmont cluster.jpg [ 24.56 KiB | Viewed 31 times ]


kind of p****d off about it but there's not alot i can do untill i determine if it's the cluster or the loom, and on top of that i dont know anyone with an el haha everyones got ef's

cheers,
Tomo

 

_________________

98%of city drivers will say ''holly s**t'' befor going into a ditch in a snowstorm and 98%of country drivers will say ''hold my beer and watch this''

Top
 Profile  
 
 
 Post subject: Re: el cluster problem's
Posted: Wed Aug 18, 2010 3:08 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

It shouldn't matter if it is an EF or an EL. The pinouts are the same.

I would be rechecking your power and earth lines in your adapter loom.

Cheers
BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: el cluster problem's
Posted: Wed Aug 18, 2010 7:34 pm 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 122

Joined: 19th Nov 2009

Gallery: 2 images

Ride: 1994 ED XR6, 2003 BA XR8

Location: Traralgon South
VIC, Australia

yea i have done that, i rechecked everything and then plugged a mate's ef cluster in and everything worked fine. then tryed the el fairmont one again and nothing.

i am seriously thinking i got ripped off here.

cheers,
Tomo

 

_________________

98%of city drivers will say ''holly s**t'' befor going into a ditch in a snowstorm and 98%of country drivers will say ''hold my beer and watch this''

Top
 Profile  
 
 
 Post subject: Re: el cluster problem's
Posted: Wed Aug 18, 2010 9:43 pm 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

Completely spit-balling here but could the BEM be incompatible?

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
 Post subject: Re: el cluster problem's
Posted: Wed Aug 18, 2010 11:14 pm 
Getting Side Ways
Offline

Posts: 5582

Joined: 20th May 2005

Gallery: 11 images

Ride: EB1 Fairmont Ghia T5 Wagon

Location: Seven Hills, Sydney
NSW, Australia

Vic wrote:
Completely spit-balling here but could the BEM be incompatible?


No, the BEM doesn't have much to do with the cluster.

I am using an EB Fairmont BEM with my setup.

Cheers
BenJ

 

_________________

BenJ's EB T5 DOHC Ghia Wagon - Current Ride
BenJ's EB GL Sedan - Previous Ride
My respect and thanks go to - snap0964, Paulmac, SWC and MRE-50L

Top
 Profile  
 
 
 Post subject: Re: el cluster problem's
Posted: Wed Aug 18, 2010 11:56 pm 
Getting Side Ways
Offline
User avatar

Posts: 6432

Joined: 5th Nov 2004

Gallery: 6 images

Oh well, I thought you had to match the BEM series with the cluster series, i.e; mid series to mid series.

 

_________________

5.6L of carbon footprint.

Top
 Profile  
 
 
 Post subject: Re: el cluster problem's
Posted: Fri Aug 20, 2010 12:28 am 
Stock as a Rock
Offline
User avatar

Age: 26

Posts: 122

Joined: 19th Nov 2009

Gallery: 2 images

Ride: 1994 ED XR6, 2003 BA XR8

Location: Traralgon South
VIC, Australia

i think i might open it up and do some testing on some things and try find out what the problem is. hopefully it's nothing to complicated/expensive to fix, i will have a look tomorrow night while i have the dash apart.

 

_________________

98%of city drivers will say ''holly s**t'' befor going into a ditch in a snowstorm and 98%of country drivers will say ''hold my beer and watch this''

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 11:29 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names