Fordmods Logo

El fuel injection replacement 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: El fuel injection replacement
Posted: Sat Oct 15, 2016 10:44 am 
Parts Gopher
Offline

Age: 26

Posts: 86

Joined: 11th Jul 2011

Gallery: 2 images

Ride: Ford Falcon ED

Location: Hobart
TAS, Australia

Hey guys i replaced my fuel injectors yesterday with a set of recod ones and when i put the fuel rail back on it didnt seem to seat injector 1 in the intake properly i could still see the yellow thing on it. anyway also replaced spark plugs with a set of xr6 ones (motorcraft) because the head and cam and that is tickford last night when i drove it home it was missing a bit under light acceleration and it died 3 times when i turned hard corners and wouldnt start unless i turned the ignition off and then kicked it over again. im going to put the old spark plugs back in (bosch platinum super + 4 thingys) and see if it does anything. is there a reason why the injector wouldnt seat in properly? did i maybe bend the fuel rail or bracket some how trying to get the prick out?
Top
 Profile  
 
 
 Post subject: Re: El fuel injection replacement
Posted: Sat Oct 15, 2016 4:54 pm 
Technical Contributor
Offline

Age: 59

Posts: 6794

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Is there an O ring still stuck in the injector port on the fuel rail?

They sometimes come off when you remove the old injectors.

 

_________________

SWC

South West Customs


Members of the SWC Stable, fordebgt93, TROYMAN, Benj, svo_matt, Mrs C, eb_fairmont, Total_tool, Terroristghia

Top
 Profile  
 
 
 Post subject: Re: El fuel injection replacement
Posted: Sat Oct 15, 2016 7:09 pm 
Parts Gopher
Offline

Age: 26

Posts: 86

Joined: 11th Jul 2011

Gallery: 2 images

Ride: Ford Falcon ED

Location: Hobart
TAS, Australia

I'll take it off and have a look tomorrow. Checked for leaks around injector with engine running seems fine. Changed plugs back. Problem was still there. Switched map sensor with the one in my ED all sorted.. The original problem I was trying to fix was really rough cold starts.. Changed oxy sensor map sensor injectors plugs and ran a tank of 98 through it. No different really. Still has flat spots on cold starts and splutters
Top
 Profile  
 
 
 Post subject: Re: El fuel injection replacement
Posted: Sat Oct 15, 2016 7:16 pm 
Parts Gopher
Offline

Age: 26

Posts: 86

Joined: 11th Jul 2011

Gallery: 2 images

Ride: Ford Falcon ED

Location: Hobart
TAS, Australia

Also have IAC disconnected and the idle speed adjusted so it won't stall on cold starts. As if I connect the IAC after resetting base idle it idles at about 1200 rpm. The ecu is an el gli auto with a j3 chip to run the manual conversion I am wondering if its the ecu? Have just purchased a manual el xr6 ecu ( I have the xr top end) hoping it might be the problem. Not keen to do the fuel pump :( filter was changed about 5 k ago could it be blocked? Have spare working sensors to try tomorrow
Top
 Profile  
 
 
 Post subject: Re: El fuel injection replacement
Posted: Sat Oct 15, 2016 7:25 pm 
Technical Contributor
Offline

Age: 59

Posts: 6794

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Check your cold air temp sensor.

 

_________________

SWC

South West Customs


Members of the SWC Stable, fordebgt93, TROYMAN, Benj, svo_matt, Mrs C, eb_fairmont, Total_tool, Terroristghia

Top
 Profile  
 
 
 Post subject: Re: El fuel injection replacement
Posted: Sat Oct 15, 2016 7:55 pm 
Parts Gopher
Offline

Age: 26

Posts: 86

Joined: 11th Jul 2011

Gallery: 2 images

Ride: Ford Falcon ED

Location: Hobart
TAS, Australia

OK is that the one beneath the throttle body? Looks like its going to be fun to get to haha. What should the voltage be? I have a spare OEM one in the shed I'll throw it in tomorrow and check for that o ring. Thanks for your suggestions mate :)
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 09, 2016 8:41 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names