Fordmods Logo

Flat spot almost fixed 


Page 1 of 1 [ 1 post ] 

 Post subject: Flat spot almost fixed
Posted: Tue Feb 19, 2013 6:04 pm 
Fordmods Newbie

Age: 53

Posts: 1

Joined: 10th Feb 2013

Ride: Falcon Ute XHII

Location: Killarney Heights
NSW, Australia

Hi Guys,My 1998 XH Ute has this story: The strainer on the fuel pump rubbed itself through on the tank floor. This would have not been so bad if no dirt could enter the system but the injector rail corroded inside as I was using the cheapest fuels I could get, ie E10, (apparently they don't have much additives in, to prevent corrosion). Anyway, some bits went to the tank via the fuel return, and eventually stuffed up the fuel pump pressure, causing a humongest flat spot. After replacing it, my flat spot is 98% gone, at times non-existent. However, even with major checking of EVERYTHING else, my occasional flat spot remains. My theory now is that the fuel pressure is not allways right, possibly due to the pump pickup position (previous hole in strainer..). However after switching off, the pressure drops to only 60 kPA, not only 10% from 225 according to an AU manual). Is this correct - what is the pressure specs on an XH, and what would be wrong that it drops - the pump is brand new?
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 6 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 21, 2016 11:49 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names