Fordmods Logo

HELP! car cuts out on turning 

 

Page 2 of 3 [ 31 posts ] Go to page Previous  1, 2, 3  Next

 
Posted: Thu Nov 25, 2004 11:05 am 
Fordmods Newbie
Offline

Age: 31

Posts: 15

Joined: 5th Nov 2004

Location: Melbourne
VIC, Australia

Im having the exact same problem on my EF Fairmont. running duel fuel (vialle system).


My power steering has a bit of a leak, would that make any difference?
Top
 Profile  
 
 
Posted: Thu Nov 25, 2004 3:14 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1500

Joined: 14th Nov 2004

Ride: Falcon

Location: SE Melb
VIC, Australia

my power steering system isn't leaking, the car battery is only six months old, there is over half a tank of fuel in the petrol tank, and I don't have an LPG kit either.

I will let you know when it happens.

 

_________________

Instant Karma is gonna get you!

Top
 Profile  
 
 
Posted: Thu Nov 25, 2004 3:17 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1500

Joined: 14th Nov 2004

Ride: Falcon

Location: SE Melb
VIC, Australia

I just rang Fordewise in Mordialloc - they reckon it's the bearings in the idle power steering pulley has siezed. the bearing have worn out and needs renewing.

The part should cost no more than $40 - im getting somewhere - GIDDY UP! :P

 

_________________

Instant Karma is gonna get you!

Top
 Profile  
 
 
Posted: Thu Nov 25, 2004 3:26 pm 
Stock as a Rock
Offline

Age: 31

Posts: 131

Joined: 15th Nov 2004

Gallery: 5 images

Ride: ED fairmont

Location: Melbourne
VIC, Australia

Let us know if that fixes the problem
Top
 Profile  
 
 
Posted: Fri Nov 26, 2004 10:40 am 
Fordmods Newbie
Offline

Age: 31

Posts: 15

Joined: 5th Nov 2004

Location: Melbourne
VIC, Australia

Yea, very interested as well mate, let us know where you get the part from, and how you install it etc.... :)
Top
 Profile  
 
 
Posted: Sat Dec 11, 2004 5:14 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1500

Joined: 14th Nov 2004

Ride: Falcon

Location: SE Melb
VIC, Australia

Posted: Mon Nov 15, 2004 12:26 pm Post subject:

--------------------------------------------------------------------------------

Try resetting the ECU and when you plug back in:

Idle in D for 2 mins
Idle in D for 2 mins w/ A/C on
Idle in N for 2 mins
Idle in N for 2 mins w/ A/C on

And work the steering wheel back and forth a couple of times under each scenario above.

Bascially trying to teach the ECU how to idle. It may help.

That didn't help as the car still cut out, even in some traffic in Melbourne.

I can trace it back to one thing - the idle speed control (ISC) solenoid.

I am taking a week off at Christmas time, and my dad knows someone who can clean this out, as I don't have the time or skills to do it (i break stuff easily). There is plans to fit a new fuel filter for good measure and a tyre rotation, plus the ususal brake adjustment and a change of oil.

I will post a reply early next year when its all finished, and when i will be back in Melbourne, as my family lives in Howlong - a small town 20 minutes from Albury.

Merry Christmas everyone and thank you for your concern.

 

_________________

Instant Karma is gonna get you!

Top
 Profile  
 
 
Posted: Tue Dec 14, 2004 6:10 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3531

Joined: 5th Nov 2004

Gallery: 25 images

Ride: 93 Maverick LWB/S2 LWB Delica

Power: 75 rwkw

Location: uoʇǝlƃuıs lʍoq ʇsnp
NSW, Australia

camh1980 wrote:

I can trace it back to one thing - the idle speed control (ISC) solenoid.


I think you have hit the nail on the head, you also should get base idle set.

 

_________________

93 Ford Maverick LWB automatic petrol guzzler (gets stuck where Deli doesn't, big pumpkins :evil:)
97 S2 Mitsubishi Delica LWB (off the road getting v8 transplant) http://tmacmechanical.com.au/

Top
 Profile  
 
 
Posted: Tue Dec 14, 2004 6:40 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1500

Joined: 14th Nov 2004

Ride: Falcon

Location: SE Melb
VIC, Australia

how do i get the base idle set?

I spoke to my local wrecker, he said to renew the ISC as its not worth mucking around with the old one. costs about $175 - bit steep, though!

 

_________________

Instant Karma is gonna get you!

Top
 Profile  
 
 
Posted: Sun Dec 19, 2004 11:17 pm 
Fordmods Newbie
Offline

Age: 31

Posts: 15

Joined: 5th Nov 2004

Location: Melbourne
VIC, Australia

Well...i had the same problem...now problem is fixed :)

First i changed the power steering pump, because that was leaking all over the alternator. Then i just changed the ISC instead of cleaning it out.

The ISC cost me $20 from the wreakers, and $80 for power steering pump.

I think that it was probably the ISC that was causing the dramas, dont know how much effect changing the power steering pump had. I tested it out...braking until i could smell the brakes, and what would you know, no stalling.

Good luck with fixing it..
Top
 Profile  
 
 
Posted: Wed Dec 22, 2004 11:35 pm 
Stock as a Rock
Offline

Age: 35

Posts: 149

Joined: 6th Nov 2004

Ride: XH Ute

Location: Dandenong
VIC, Australia

my car does this once i a blue moon when turning on the full lock, but usually in reverse

 

_________________

The Ute with the Most

Top
 Profile  
 
 
Posted: Tue Dec 28, 2004 6:23 pm 
Fordmods Newbie
Offline

Age: 53

Posts: 3

Joined: 28th Dec 2004

Ride: EF FUTURA

Location: ararat
VIC, Australia

I have had same prob with my ef futura on factory gas, but only slalls at intersections when running on gas , never on petrol.
had converter reconditioned but still does it so just run on petrol now
Top
 Profile  
 
 
Posted: Sat Feb 05, 2005 1:08 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1500

Joined: 14th Nov 2004

Ride: Falcon

Location: SE Melb
VIC, Australia

I got the problem fixed a couple of weeks ago. My mechanic cleaned out the throttle body as it was dirty and the airflow was restricted when I applied the brakes to slow down. It only set me back $60, orginally quoted $80. A new ISC unit cost $100 - not needed in this case! Thank you for everyone who has been concerned.

Now, just to sell the secondhand ISC unit I have sitting around at home..............

 

_________________

Instant Karma is gonna get you!

Top
 Profile  
 
 
Posted: Tue Apr 19, 2005 7:32 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1500

Joined: 14th Nov 2004

Ride: Falcon

Location: SE Melb
VIC, Australia

Everybody, the stalling has been occuring again. The car stalled making a left hand turn - in a 60 km/h zone! The car needed to be started three times before it got fully going again. This si due to the fact I cleaned th engine at my local car wash.

Some water had got into the distributor cap, as a result the distributor points were corroded - all white. So the distributor cap was replaced, as well as the rotor button (that was almost worn out, rough marks on one side), spark plugs and spark leads. I also got the engine tuned as well.

The car runs fine when in park, but still feels as its going to die when slowing down to a traffic light, or making a turn at a corner.

The ISC unit has been cleaned out with carby cleaner.

My mechanic has asked to put the car on a diagnostic machine, maybe the fault will show up there?

Will also ask my mechanic about the power steering switch.

Any more suggestions, please help me..........

 

_________________

Instant Karma is gonna get you!

Top
 Profile  
 
 
Posted: Wed Apr 20, 2005 1:18 am 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 3531

Joined: 5th Nov 2004

Gallery: 25 images

Ride: 93 Maverick LWB/S2 LWB Delica

Power: 75 rwkw

Location: uoʇǝlƃuıs lʍoq ʇsnp
NSW, Australia

Has base idle been set, did you keep and try the other ICS.

It is easy to check if base idle is adjusted correctly, unplug the ICS while in park/neutral while engine is running, if it stops the base idle is to low, it should just idle at a low rpm.

 

_________________

93 Ford Maverick LWB automatic petrol guzzler (gets stuck where Deli doesn't, big pumpkins :evil:)
97 S2 Mitsubishi Delica LWB (off the road getting v8 transplant) http://tmacmechanical.com.au/

Top
 Profile  
 
 
Posted: Wed Apr 20, 2005 5:10 pm 
Getting Side Ways
Offline

Age: 37

Posts: 1500

Joined: 14th Nov 2004

Ride: Falcon

Location: SE Melb
VIC, Australia

I got an ISC unit today for $35 - and disconnected the battery for 20 minutes, car is running fine now.

Will leave any more notes regarding any more problems.

 

_________________

Instant Karma is gonna get you!

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 2 of 3  [ 31 posts ]  Go to page Previous  1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 19 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 7:53 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names