Fordmods Logo

lack of power on feul 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: lack of power on feul
Posted: Sun Apr 26, 2009 12:12 am 
Fordmods Newbie
Offline

Age: 66

Posts: 11

Joined: 25th Apr 2009

Ride: Ford Ltd df 1996

Location: Melbourne
VIC, Australia

I'm driving a Ford Ltd with a windsor V8 on deul feul petrol/LPG I have changed on it the feul pump, feul filter and new feul injectors. Well on LPG it's ok,but on petrol it starts, run on idle ok but when put it gear it seems to loss power it stalls.
Any help Please
Top
 Profile  
 
 
 Post subject: Re: lack of power on feul
Posted: Sun Apr 26, 2009 10:19 am 
Fordmods Newbie
Offline

Posts: 19

Joined: 17th Mar 2006

Ride: EF Fairmont

Location: Adelaide
SA, Australia

Most probably have partially blocked injectors, or maybe a lazy MAF sensor ( gas backfire ?). Rip the injectors out and get them ultrasonically cleaned and flow tested. Mike

 

_________________

EA Falcon Saloon RaceCar
EF Fairmont wagon- AU I6 modified
EB Ford daily
EB Ford daily- AU I6 modified

Top
 Profile  
 
 
 Post subject: Re: lack of power on feul
Posted: Sun Apr 26, 2009 11:50 am 
Fordmods Newbie
Offline

Age: 66

Posts: 11

Joined: 25th Apr 2009

Ride: Ford Ltd df 1996

Location: Melbourne
VIC, Australia

Thank Mike for that promt response, where would theMAF sensor be on the engine, and the feul injectors are brand new is that nessesarly to clean them.
Thank You
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 11 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 9:22 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names