Fordmods Logo

new fuel pump whines all the time guage dances empty to full 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: new fuel pump whines all the time guage dances empty to full
Posted: Mon Oct 11, 2010 1:42 pm 
Getting Side Ways
Offline

Posts: 534

Joined: 14th Oct 2007

Gallery: 8 images

Location: newcastle
NSW, Australia

hey guys fairmont died the other day after running out of fuel .
replaced the fuel pump (delphi) an relays next to the battery green,brown.filter is near new and the injectors clack away less than 12mths old.

anyway started good but it now whines all the time and when the tanks is full the needle jumps from full to empty and the car misses ever so slightly when doin so ,
to the point of when i feel miss i look down to see the fuel guage drop.
do yas reckon the fuel sender is getting old? or i havent put it in correct somthing like that?
any tips would be awesome cheers Mystro
Top
 Profile  
 
 
 Post subject: Re: new fuel pump whines all the time guage dances empty to full
Posted: Sun Oct 24, 2010 7:23 am 
Fordmods Newbie
Offline

Age: 53

Posts: 2

Joined: 22nd Jul 2009

Ride: Ford Fairlane / NF

Location: Shellharbour
NSW, Australia

.
This isn't a solution (sorry), but I fitted a new Bosch pump to my Fairlane a few weeks back, "The quietest pump on the market" the ad said.
It whines like my ex-girlfriend!

I haven't filled the tank with it yet to see if i have the same dancing gauge issues, but it runs fine otherwise when I flick to petrol from LPG.

Greg
Top
 Profile  
 
 
 Post subject: Re: new fuel pump whines all the time guage dances empty to full
Posted: Sun Oct 24, 2010 7:48 am 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

mystro wrote:
hey guys fairmont died the other day after running out of fuel .
replaced the fuel pump (delphi) an relays next to the battery green,brown.filter is near new and the injectors clack away less than 12mths old.

anyway started good but it now whines all the time and when the tanks is full the needle jumps from full to empty and the car misses ever so slightly when doin so ,
to the point of when i feel miss i look down to see the fuel guage drop.
do yas reckon the fuel sender is getting old? or i havent put it in correct somthing like that?
any tips would be awesome cheers Mystro


Sounds like an electrical fault. Power to sender as well as pump, 1) power cuts, 2) pump stops, 3) gauge drops, 4) car misses. As for whining, check to senure it is firm in it's cradle.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 8:21 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names