Fordmods Logo

Possible I.C.S. problem? 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Possible I.C.S. problem?
Posted: Sun Oct 02, 2011 7:18 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Hi all,
My EF (L6) has developed an annoying habit of not idling properly, so I'm thinking the Idle Control Solenoid is acting up. However, would this also cause it to not maintain revs in neutral as well? I'll try to hold it at 2000 rpm (for example) and the revs will just fall away. In gear at the lights she'll almost stall at times. Also there is a slight miss developing too. Other than those issues everything else is fine.
There is nothing else I can think of that would be causing these problems: Coil pack, plugs, leads, injectors and fuel reg have all been replaced recently so I doubt they are the cause.
Any thoughts?

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: Possible I.C.S. problem?
Posted: Mon Oct 03, 2011 12:59 pm 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

Well today I took the I.C.S. off and gave it a clean out and gave the throttle body a dose of cleaner but it made absolutely no difference :x .
One other thing I forgot to mention before, sometimes the revs will 'hang' as well. Almost like the butterfly isn't closing, but it doesn't stick or jam when I move it by hand. Any ideas? Cos this is getting annoying very rapidly.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
 
 Post subject: Re: Possible I.C.S. problem?
Posted: Mon Oct 03, 2011 3:23 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Check Vac leaks.
Top
 Profile  
 
 
 Post subject: Re: Possible I.C.S. problem?
Posted: Tue Oct 04, 2011 10:42 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 843

Joined: 20th Feb 2010

Gallery: 2 images

Ride: AU Fairmont Ghia

Location: Elizibif Norf (Local Spelling!!)
SA, Australia

SWC wrote:
Check Vac leaks.

Sir, I tip my hat to you.. :)

It was indeed a vacuum leak. The vacuum hose running to the fuel pressure regulator had a MASSIVE split in it. I was amazed she was still running :shock: .
Replaced it this morning. The result? One very happy car idling as smooth as a baby's bum again.

 

_________________

dc_todd wrote:
Cheap pads squeal like cheap hookers, and you can take that to the bank.


Au Fairmont Ghia
My (Old) 95 EF Wagon

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 1:07 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names