Fordmods Logo

Problems on petrol - choke and splutters at revs! UPDATED! 

 

Page 3 of 3 [ 40 posts ] Go to page Previous  1, 2, 3

 
Posted: Wed Feb 22, 2006 12:06 am 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

No probs dude. It's also handy as it proves the ECU power relay is operating, and you can check if you're getting 12v to your engine electrics, such as ISC, injectors, etc.

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Mon Mar 06, 2006 2:26 pm 
Fordmods Newbie
Offline

Age: 51

Posts: 2

Joined: 6th Mar 2006

Location: Morisset
NSW, Australia

This might sound silly, But I had a car some time ago, that had similar problems and I replacd just about everything to do with the fuel system and ignition system as well just to be sure.

After all that I couldnt get the car to run. So I eventually took it to a bloke an older fella that took one look and started replacing all the vacuum lines and low and behold the car ran and ran well. for the cost of some vacuum lines worth a try.
Top
 Profile  
 
 
Posted: Mon Mar 06, 2006 8:27 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2833

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

Damn EFI, my car has been playing up for aver a year and a half now - missfire/surge under load with under 3000 revs, if i grandpa it around for a while (not letting it get over about 1200 revs) it doesnt do it, and if i drive for about 15-20 mins it will usually go away. it happened around the time i got my exhaust done (so it could be an electrical/computer gremlin from them welding on the car) and about the same time i almost ran out of fuel once so it could be a fuel system fault ive replaced:

Fuel pump
battery
TPS
Coolant temp sensor
MAP
OXY

next is a fuel injector service and fuel reg,
then Dizzy +coil
then ECU
then maybe a new exhaust (they may have used the wrong sealant and f**k the cat)

but it still goes well under full throttle!

 

_________________

Because i can.

Top
 Profile  
 
 
Posted: Tue Mar 07, 2006 5:56 pm 
Getting Side Ways
Offline

Age: 35

Posts: 533

Joined: 12th Jan 2005

Location: Melbourne
VIC, Australia

twr7cx wrote:
unclewoja here's a picture of the modified/cut down tank. it looks like they cut the tank in half and got rid of the side that is closes to the tailgate to fit the LPG tank in next to it. it only holds about 35/40L.
[image]http://img362.imageshack.us/img362/6715/dscn13967mi.jpg[/image]
http://img362.imageshack.us/img362/6715/dscn13967mi.jpg


I'm a bit lost with that picture. I can't get my orientation right or see the pump. I can't really tell if they've cut away the baffles in the tank.

My money's still on airrated fuel, but these problems are usually very hard to diagnose and only makes sense after you've solved the problem.

You can get fuel flow meters which is basically a ball in a glass tube like, the guage on a kettle. It's not the right thing to do, but if you can get a loan of something like that, hook it up and drive around, it will show up any air bubbles in the fuel if there are any.

Only problem is you'd need to drive with the bonnet slightly open and place the flow meter on the windscreen so you can see if whilst driving, hence why it's really not the right thing to do.
Top
 Profile  
 
 
Posted: Tue Mar 07, 2006 8:15 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

hmmmm...
pictures taken standing at the back of the car. you can't see the pump as it's in the center of the tank, access through a hole one the passenger side under neath the car and you ahve to pull a whole long unit thingo out with the fuel level sensor and al that crap on it.

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Wed Mar 08, 2006 11:21 am 
Fordmods Newbie
Offline

Posts: 7

Joined: 19th Feb 2006

Location: Toowoomba
QLD, Australia

Have you tried replacing the fuel relay yet?
because of the way they're made (fine wire coil etc) if there's a fracture in the wire it can still be connected when it's cold, but as the relay heats up and the wire expands the fracture separates and connection becomes broken or weak. Dizzy can get the same problem with the sensor (found that out the hard way after replacing rest of the ignition system)

i recommend replace if you haven't already
Top
 Profile  
 
 
Posted: Sun May 07, 2006 2:57 pm 
Fordmods Newbie
Offline

Age: 37

Posts: 1

Joined: 28th Dec 2004

Location: Hobart
TAS, Australia

I have a xg panel van and i have got the same problem 4.0l efi. have also repaced alll of the things mentioned how did you fix it in the end? please i am doing my mind in!!!
Top
 Profile  
 
 
Posted: Sun May 07, 2006 9:09 pm 
Getting Side Ways
Offline

Age: 31

Posts: 3893

Joined: 15th Nov 2004

Gallery: 24 images

Ride: BF MKII V8 Fairmont Ghia

Location: Perth
WA, Australia

just a slightly unrelated question.

what do you guys use to join the pins to get into dianostics mode? home made connectors?

 

_________________

2007 Steel BF Ghia MKII V8 - 19" GTP's + Superlows

Top
 Profile  
 
 
Posted: Sun May 07, 2006 9:20 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 1380

Joined: 6th Nov 2004

Gallery: 3 images

Ride: FPV BF MKII F6

Location: Brisbane
QLD, Australia

my faulty fuel reg caused this

 

_________________

OBS35N is gooonnnneeee.
Gone for good..... Damn fence posts!!!!!

OBS35N #2 (XXF6XX) just bought, bring it on

Top
 Profile  
 
 
Posted: Tue May 09, 2006 4:46 pm 
Parts Gopher
Offline

Age: 31

Posts: 73

Joined: 7th Nov 2004

Ride: EF Farimont

Location: Canberra
NSW, Australia

do you have a mate with another ef/el try swapping the map sensor. i have seen gas backfires damage them then they run like a pig afterwards.

and it would only take 5 min to try.

 

_________________

1997 Ford EL Fairmont
Blue Dash Mod
Red LCD mod
Full Alpine Sterio
Pedders Super Low Sports Rider Suspension
CSA avenger 17x8 (235/45 front) (255/40 Rear)
DBA slotted Rotors (front & Back)
EBC Greenstuff pads (front & Back)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 3 of 3  [ 40 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 1:30 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names