Fordmods Logo

runs fine on gas, but very poor on petrol? :-( 

 

Page 1 of 1 [ 10 posts ] 

 
 Post subject: runs fine on gas, but very poor on petrol? :-(
Posted: Sat Jul 22, 2006 4:15 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 740

Joined: 20th Nov 2004

Ride: BA Falcon

Location: Melbourne
VIC, Australia

howdy, 95 ef falcon with aftermarke impco gas system.

now it runs like a dream on gas, but like a peice of s**t on petrol.

ive changed the fuel filter, re-gapped the plugs, all the usual stuff... but it still runs really bad on petrol. it stalls unless you have your foot on the throttle,

the only thing i can think could be causing it is the oxy sensor? or blocked injectors.

any other ideas?
Top
 Profile  
 
 
Posted: Sat Jul 22, 2006 4:23 pm 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

sounds like blocked injectors or something along those lines...
Top
 Profile  
 
 
Posted: Sat Jul 22, 2006 5:27 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 4323

Joined: 17th Jan 2006

Ride: Soarer 2.5GT-T

Location: Cranbourne
VIC, Australia

i have this problem with my el mont and impco gas.
changed injectors and it's no good. so i dunno man, won't work for me!
Top
 Profile  
 
 
Posted: Sat Jul 22, 2006 5:35 pm 
Getting Side Ways
Offline
User avatar

Posts: 1552

Joined: 26th Oct 2005

Ride: Falcon

Location: Melbourne
VIC, Australia

does the engine feel like its 'stuttering' when you drive it at take off?

 

_________________

SIGNATURE REMOVED - REFER TO FORUM GUIDELINES!

Top
 Profile  
 
 
Posted: Sat Jul 22, 2006 5:38 pm 
Fordmods Addict
Offline

Age: 32

Posts: 2245

Joined: 5th Nov 2004

Ride: BA XR6T

Location: Bayswater
VIC, Australia

hmm, on my wagon which has an impco system (i think) i get less kays on petrol than on gas. car also runs a little rough on petrol, not too bad. but the guy i bought it of said it was tuned for gas. dont know whether he was s**t or not tho

 

_________________

Image

Top
 Profile  
 
 
Posted: Sat Jul 22, 2006 5:38 pm 
Technical Contributor
Offline
User avatar

Age: 53

Posts: 5587

Joined: 14th Jan 2005

Gallery: 10 images

Ride: 96 XH/97 EL

Location: South Coast
NSW, Australia

How often were you running it on petrol ???

 

_________________

96 XH Longreach 'S': LPG, Alarm, 3.23:1 LSD, Cruise, Trip Comp, ABS, Power Windows, Mid Series Dome Lt, Climate Ctrl
97 EL Futura S/W: LPG, Alarm, LED int Lts, Trip Comp, F/Lane Dome Lt, Climate Ctrl, T5 Conversion

Top
 Profile  
 
 
Posted: Sat Jul 22, 2006 5:47 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 4307

Joined: 5th Nov 2004

Gallery: 9 images

Ride: EF Falcon XT-T

Location: Mornington Peninsula
VIC, Australia

my car got mostly run on LPG, injectors ended up being clogged up, and i've killed 2 fuel pumps.
those would be the 2 main things to look into.

 

_________________

FALCN6 - EF GLi Turbo, 20" Rims, Air Bag Suspension, Straight LPG, 225rwkw
DTHWGN - EA GL Wagon, LTD Interior, Satin Black, 5.0, Turbo
RACER - EF Futura , 5.0, 5 Speed
PROJECT - 83 Thunderbird, Lowered, 18" Billet Wheels
DAILY - BA Fairmont Ghia 5.4 3V

Top
 Profile  
 
 
Posted: Sat Jul 22, 2006 5:56 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

your fuel system goes to the s**t when it's just being left sitting around not being used. could be anything from clogged lines, old fuel, dodgy pump, blocked injecytors, blah blah blah...

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Wed Jul 26, 2006 9:02 pm 
Getting Side Ways
Offline
User avatar

Age: 30

Posts: 740

Joined: 20th Nov 2004

Ride: BA Falcon

Location: Melbourne
VIC, Australia

it rarely ever got used on petrol, so i wouldnt be surprised if everything was clogged to the s**t,

it hardly pushes the car along when its on petrol, and it wont idle if my foot is off the throttle. its gotta be about 1/2 open and around 1500-2500rpm for it to keep running without almost stalling...

i might see how much its gunna be to clean the fuel system - injectors, rail, lines, pump etc)

cheers for the replys fellas
Top
 Profile  
 
 
Posted: Thu Jul 27, 2006 9:16 pm 
Smokin em up
Offline

Posts: 236

Joined: 1st Sep 2005

Ride: EL Ghia Tickford 5.0

Location: Adelaide
SA, Australia

blocked injectors for sure.

 

_________________

EL Fairmont Ghia 5.0
Sunroof - Leather - 3" Exhaust - 19" GTP's - Tickford Kit

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 10 posts ] 

Who is online

Users browsing this forum: Facebook [Bot] and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 10:20 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names