Fordmods Logo

Ticking / clicking BEM 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: Ticking / clicking BEM
Posted: Mon Jan 25, 2010 8:08 pm 
Getting Side Ways
Offline
User avatar

Posts: 1043

Joined: 7th Feb 2005

Location: Canberra
ACT, Australia

Ok ive had the battery out of my EL XR8 for a few weeks while ive been doing some work on it, on a trickle charger.
I start the car today and theres this ticking from the BEM, like an indicator relay tick, goes for about a minute and stops, then after a minute it starts up again. Pull the CRT fuse and it still does it. Only way to stop is to disconnect the battery. Had two ELs for four years total and never seen this before, not much on the forum either.
Car cranks, starts and runs fine, no battery issue. Havnt driven it, but I though id post this up first.
Any ideas?

 

_________________

1993 ED XR6 5speed Polynesian Green. Project car.

1998 EL XR8 Auto Hot Chilli Red. New daily and project

Top
 Profile  
 
 
 Post subject: Re: Ticking / clicking BEM
Posted: Mon Jan 25, 2010 9:05 pm 
Getting Side Ways
Offline
User avatar

Posts: 1043

Joined: 7th Feb 2005

Location: Canberra
ACT, Australia

Ok took it for a drive and everything is fine, but the clicking still persists. If im just cruising along it doesnt click, as soon as I hit the brake, interior light, indicator, window switch, etc it starts to click again for about a minute.

 

_________________

1993 ED XR6 5speed Polynesian Green. Project car.

1998 EL XR8 Auto Hot Chilli Red. New daily and project

Top
 Profile  
 
 
 Post subject: Re: Ticking / clicking BEM
Posted: Tue Jan 26, 2010 2:53 pm 
Getting Side Ways
Offline
User avatar

Posts: 1043

Joined: 7th Feb 2005

Location: Canberra
ACT, Australia

Well it turns out it was the alarm control box that was clicking, which must of blown a fuse when I connected the battery.

 

_________________

1993 ED XR6 5speed Polynesian Green. Project car.

1998 EL XR8 Auto Hot Chilli Red. New daily and project

Top
 Profile  
 
 
 Post subject: Re: Ticking / clicking BEM
Posted: Wed Feb 24, 2010 9:49 pm 
Getting Side Ways
Offline

Age: 29

Posts: 454

Joined: 31st Mar 2005

Gallery: 8 images

Ride: 05 XR6 Mk II Falcon Ute

Location: thornton
NSW, Australia

what fuse was it that blown and where is the alarm box that was ticking.

my bem is ticking and i have no power to the dash or any thing was fine yesterday......

 

_________________

EL Futura 5 speed factory:PH47FL goneeeee :(
04 BA XR6 Mk II Sedan: XR67OY gonneee..
2010 250R ninja: gooneeee.
BF 2007 F6 typhoon:F6FOON gonnnee.
05 BA XR6 Mk II Ute: latest

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 7:19 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names