Fordmods Logo

walbro fuel pump makes car run rich 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: walbro fuel pump makes car run rich
Posted: Fri May 27, 2011 10:47 pm 
Stock as a Rock
Offline

Age: 28

Posts: 182

Joined: 9th Jan 2011

Gallery: 4 images

Ride: 2004 ba xr6 turbo

Location: sydney
NSW, Australia

i just installed a walbro fuel pump that is 255L per hr and my car barely starts and when it does it blows thick black smoke and it sounds very lumpy through the exhaust. I had the flash tuner on to it and leaned out the car but still having the same problem, less smoke though but car still barely starts and wen it does is very lumpy should this be happeneing if so is it a matter of getting a new tune, due to the increased amount of fuel flowing in to the engine?
Top
 Profile  
 
 
 Post subject: Re: walbro fuel pump makes car run rich
Posted: Fri May 27, 2011 10:50 pm 
Oompa Loompa
Offline
User avatar

Age: 26

Posts: 44

Joined: 22nd May 2010

Ride: 1992 XF ute w/T5

Location: bannockburn
VIC, Australia

adjust the fuel pressure reg

 

_________________

CHEERS MARK

CUT BAIT OR GO FISHING!

Top
 Profile  
 
 
 Post subject: Re: walbro fuel pump makes car run rich
Posted: Sat May 28, 2011 11:07 am 
Stock as a Rock
Offline

Age: 28

Posts: 182

Joined: 9th Jan 2011

Gallery: 4 images

Ride: 2004 ba xr6 turbo

Location: sydney
NSW, Australia

awesome that worked, car is all good...thanks heaps
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 3:42 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names