Fordmods Logo

03 BA problems 

 

Page 1 of 1 [ 4 posts ] 

 
 Post subject: 03 BA problems
Posted: Wed Mar 15, 2017 9:19 pm 
Fordmods Newbie
Offline

Age: 19

Posts: 2

Joined: 20th Sep 2016

Ride: 2003 BA XR6

Location: Hobart
TAS, Australia

So I'm having some issues with my 03 NA Falcon, basically it's getting around 380kms to a tank (16.1l/100km) apparently. I've replaced everything the mechanics suggested including;

New plugs
02 sensor
New coil packs
All fluids and coolants
All filters

All of this was done in the last 2-3000kms. The only modifications are extractors, a 2/5inch exhaust and mace intake.

The problem I'm having is the car seems to lose power when accelerating every now and then and feels as if it's going to stall. It feels as if it puts itself into a higher gear and won't rev, that's the best way I can describe it. The ABS light recently has come on and causes issues with the breaks but I don't think this would be related?

If anyone has an answer please help because I've thrown a lot of money at fixing things and nothing seems to do it!

Cheers
Top
 Profile  
 
 
 Post subject: Re: 03 BA problems
Posted: Wed Mar 15, 2017 10:35 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3448

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

Have you checked the Throttle Position Sensor yet? Checked for exhaust or intake leaks?check all the bolts for the inlet and exhaust manifold?
Top
 Profile  
 
 
 Post subject: Re: 03 BA problems
Posted: Wed Mar 15, 2017 11:14 pm 
Stock as a Rock
Offline

Age: 64

Posts: 140

Joined: 4th Feb 2016

Location: australia
VIC, Australia

Go back to your mechanic and get him to check all the live data with a scan tool, too many possible problems. Air leaks in the exhaust, air leaks in your inlet manifold, they run a tmap system in that vacuum and inlet air temp, app pedal and a duty cycled throttle body five functions there alone, variable valve timing and so on, without a scan tool looking at live data you are pissing in the wind.
Top
 Profile  
 
 
 Post subject: Re: 03 BA problems
Posted: Wed Mar 15, 2017 11:19 pm 
Fordmods Newbie
Offline

Age: 19

Posts: 2

Joined: 20th Sep 2016

Ride: 2003 BA XR6

Location: Hobart
TAS, Australia

rod hansen wrote:
Go back to your mechanic and get him to check all the live data with a scan tool, too many possible problems. Air leaks in the exhaust, air leaks in your inlet manifold, they run a tmap system in that vacuum and inlet air temp, app pedal and a duty cycled throttle body five functions there alone, variable valve timing and so on, without a scan tool looking at live data you are pissing in the wind.

Thanks for the quick reply. I've been tossing up taking it to Ford as I thought they might have better means of testing that sort of stuff but I've heard nothing but bad news from them in Tassie. My question is; is my ordinary mechanic able to test these things or would I need to book in to a performance shop or ford?

And I haven't changed the TPS yet as I didn't want to spend money on that too and it turns out it's fine. Thanks for the quick replies!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 4:35 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names