Fordmods Logo

Fordmods Advertising

2006 eb falcon on gas/petrol lost some elecs while driving, 


Page 1 of 1 [ 1 post ] 

 Post subject: 2006 eb falcon on gas/petrol lost some elecs while driving,
Posted: Sat Mar 05, 2011 10:25 am 
Fordmods Newbie

Posts: 1

Joined: 5th Mar 2011

Ride: ford falcon

Location: melb
VIC, Australia

my falcon was put on gas about 2 1/2 years ago after we bought it. for the last 8 months its been idling crap on gas, and just thelast couple of weeks, i have had a lot of trouble starting the car, if i run on petrol and start on petrol no probs, but sometimes when i switch to gas while driving it cuts out.

last week after much nagging (8 months worth) hubby put no coli packs on, hes said its had the plugs changed too.

yesterday i was driving home from docklands, (about 20 minutes of mid afternoon traffic) and the abs light came on, there was a truck slowing in front of me, iput my foot on the brake and the anti skid light came on, a couple of other lights flickered, but as i lost all accelaration at the same time, i didnt notice which ones.

i could only take off slowly, it was like the accelerator cable was stretching, not pulling if you know what i mean, then the speedo died, the numbers were there but the needle didnt move, tacho oil and fuel still working.

i dropped my friend at her car, but didnt turn the engine off, taking off was very slow, still no speedo, brakes and steering felt heavy, pedal was hard, then all the lights on the radio panel cut out, at this point, i put my hazards on and drove slowly in the left side of the lane all the way home,

i parked on our fairly steep drive, and waited for the garage door to open, trying to get into the garage was fun, i had my foot flat on the accel, and the other above the brake, the car inched up the drive into the garage (yeah i should have left it in the drive!)

rang hubby, he took it to his workshop this morning, of course the car didnt miss a beat! i drove to pick him up, and he took me for a drive, no problems, what the hell??

the people who fitted the gas are in the next workshop (dont even go there), he (finally)asked them for advice, they have ordered a gas computor.

but what about the elecs? could this be the faulty barrel problem i read about on this site??

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: Google [Bot] and 24 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 2:45 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names