Fordmods Logo

94 ef battery losing its charge 


Page 1 of 1 [ 3 posts ] 

 Post subject: 94 ef battery losing its charge
Posted: Sat Apr 02, 2011 5:10 pm 
Fordmods Newbie

Age: 27

Posts: 3

Joined: 24th Feb 2011

Ride: Ford Falcon EF

Location: Eschol Park
NSW, Australia

hey guys, i did do a bit of a search, found dribs and drabs, but nothing has helped me.
ive got a 94 ef futura. driving around camden last week it went perfect. hopped out, walked around for bout 5 minutes, hopped back in, tried to start but it seemed as if the battery as dead. a mate of mine came to jump start me, got it going but now the battery light was starting to flash. drove alright for about 20 metres then conked out as soon as i put the headlights on. i parked it and left it there over night, took the battery home to chuck it on charge. next morning, drove back to my car, put the battery back in, started up fine, no battery light flashin, got home to campbelltown about 10-15kms away. got home, turned the car off tried to crank it again but battery seemed to off losed its charge on the way home.

now, this weekend, ive finally got some time to check up on it,started it with a fully charged battery, this time i got a descent multimeter, hooked up the multimeter to the battery while the car was running, and it
was reading 17 volts? it peaked at 18-19.
i stopped the car, tried to crank it again, but was as if the battery was dead. put the multimeter back on
and it was still reading around 16V with the terminals disconnected.

i asked the previous owner how old the alternator was and he said it was installed about 6 months before i bought the car, and it was brand new, still looks brand new too.

anyone have any ideas?

thank you heaps!
 Post subject: Re: 94 ef battery losing its charge
Posted: Sat Apr 02, 2011 9:18 pm 
Oompa Loompa

Posts: 21

Joined: 22nd Sep 2007

Ride: Fairmont

Location: Cairns
QLD, Australia

just had a similar thing happen to my EF fairmont, firstly get your battery tested mine had a faulty battery & faulty voltage regulatoron the battery.
 Post subject: Re: 94 ef battery losing its charge
Posted: Sat Apr 02, 2011 11:48 pm 
Getting Side Ways
User avatar

Age: 52

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

If your getting 17-19 volts I'd say your regulator is stuffed, and probably frying your battery.



She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 8:51 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names