Fordmods Logo

Annoying surge on deceleration 

 

Page 1 of 2 [ 25 posts ] Go to page 1, 2  Next

 
 Post subject: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:04 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

As some of you guys know the auto in my EB packed up after 310,000 hard kms. So i converted it to manual. I was getting a bad rev hang issue so i temporarily disconnected the ISC. But i got sick of it not idling when cold or idling up when the A/C was on or dry steering and stalling. and while the ISC was disconnected it wouldn't idle on petrol but it did on gas.

Anyway i'm rambling. Found out how to stop the rev hang, thanks TROYMAN, and fixed it on the weekend, now the idle behaves.
Now on gas it's all sweet but on petrol when to accelerate ever so slightly or you say build up revs to like 3000rpm and back off when it gets below say 2000rpm it starts to shudder/surge really badly until you put the clutch in or accerate again

what do you guys think?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:17 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1166

Joined: 31st Mar 2005

Gallery: 2 images

Ride: ef falcon, el fairmont ghia

Location: Christchurch
New Zealand

i think you're in the wrong gear
Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:25 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

If the engine is running 100% on LPG I'd be looking at your petrol injection gear as the first point of call.

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:25 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

Troy wrote:
i think you're in the wrong gear


thats helpful how?

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:29 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

ToranaGuy wrote:
If the engine is running 100% on LPG I'd be looking at your petrol injection gear as the first point of call.

Cheers

ToranaGuy


i originally thought TPS. swapped plugs over with the now un needed auto TPS. changed back to the original non Tickford fuel pressure regulator. swapped injectors and rail with the SVO ones. and pressure tested the fuel pump. all sweet. oh and new fuel filter

still does it

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:40 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

WILDEB wrote:
ToranaGuy wrote:
If the engine is running 100% on LPG I'd be looking at your petrol injection gear as the first point of call.

Cheers

ToranaGuy


i originally thought TPS. swapped plugs over with the now un needed auto TPS. changed back to the original non Tickford fuel pressure regulator. swapped injectors and rail with the SVO ones. and pressure tested the fuel pump. all sweet. oh and new fuel filter

still does it


Interesting. Been thru the book on this one. I know my TPS is playing up on my EB, or should I say the signal from it to the ECU, which could be either wiring loom or the TPS itself. It's not an electrical issue like a dodgy earth on the o2 sensor is it?

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:46 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

ToranaGuy wrote:
WILDEB wrote:
ToranaGuy wrote:
If the engine is running 100% on LPG I'd be looking at your petrol injection gear as the first point of call.

Cheers

ToranaGuy


i originally thought TPS. swapped plugs over with the now un needed auto TPS. changed back to the original non Tickford fuel pressure regulator. swapped injectors and rail with the SVO ones. and pressure tested the fuel pump. all sweet. oh and new fuel filter

still does it


Interesting. Been thru the book on this one. I know my TPS is playing up on my EB, or should I say the signal from it to the ECU, which could be either wiring loom or the TPS itself. It's not an electrical issue like a dodgy earth on the o2 sensor is it?

Cheers

ToranaGuy


i should probably check it for codes. the o2 sensor is about 12 months old.

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Wed Apr 27, 2011 11:54 pm 
Getting Side Ways
Offline
User avatar

Posts: 807

Joined: 28th Oct 2008

Location: melburn
VIC, Australia

you have a cam with no tune dont you?
that will effect the way the car runs at low revs, especially at low or no throttle open as its just dumping fuel in due incorrect vacuum readings from the cam.

have you noticed any consistent numbers?
ie. does it do it in every gear, any load, at speed, etc.

give us some more info.

have you tried cleaning your ISC and is your base idle set correctly?
no vacuum leaks of any kind?

on petrol the manifold pressure is more of an issue as its obviously using that as a reference for the fuel map, but its not so important on gas as long as there is no large vacuum leak.

check your plugs, if they are sooted, hit them with a wire wheel and see if the problem remains

 

_________________

XG Panelvan
mild engine, EL ECU & J3, HI6 & MSD coil

in the shed - .595" lift cam, GT4202, forged AU engine, ems 4424 ecu, glide & 5500 stall - next-bellhousing

XH ute daily - DOHC BA XR6 engine, T5, AU3 ECU, J3 chip, wideband & logger, ported BBM, 3" intake

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Thu Apr 28, 2011 8:16 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

misk_one wrote:
you have a cam with no tune dont you?
that will effect the way the car runs at low revs, especially at low or no throttle open as its just dumping fuel in due incorrect vacuum readings from the cam.

have you noticed any consistent numbers?
ie. does it do it in every gear, any load, at speed, etc.

give us some more info.

have you tried cleaning your ISC and is your base idle set correctly?
no vacuum leaks of any kind?

on petrol the manifold pressure is more of an issue as its obviously using that as a reference for the fuel map, but its not so important on gas as long as there is no large vacuum leak.

check your plugs, if they are sooted, hit them with a wire wheel and see if the problem remains


i do have a cam thats running untuned. but when it had the 3.9 and auto i had a bigger cam and it ran sweet. but for some reason now it overfuels at idle like a b**ch.
it only does it in lower revs while coasting up to a intersection etc (say in 2nd gear)
i changed the ISC to a good one that come of a running well car. the old one used to play up alot
the plugs are about 5 months old. proper gas plugs

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Fri Apr 29, 2011 12:14 am 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

Proper gas plugs? Zgr6b11's? What gap you running?

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Fri Apr 29, 2011 8:20 am 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

ToranaGuy wrote:
Proper gas plugs? Zgr6b11's? What gap you running?

Cheers

ToranaGuy


can't remember the brand but yeah they are. have the extra long electrode on them

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Fri Apr 29, 2011 7:14 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

The differance of the electrode length from the ea to eb 2 is about 3mm hey. I had ed plugs in my ea and it burn fuel very poorly.

Mate your not just feeling backlash from the dif are you?
Or possibly from a worn T5.
My diff is whining and has heaps of backlash when I coast to a stop in 1st or 2nd.
My advice. Left foot down....
Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Fri Apr 29, 2011 8:43 pm 
Stock as a Rock
Offline

Age: 25

Posts: 191

Joined: 30th Dec 2010

Gallery: 2 images

Ride: Ford Falcon EA

Location: Ballarat
VIC, Australia

i have the same problem WILDEB but it doesnt do it all the time when on gas, just every now and then. but it hasnt been so much of an issue but i would like to fix it aswell. my cam is standard and runs perfect on gas and petrol. so comparing the 2 it shouldnt be the cam. could compression have anything to do with it?
Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Sat Apr 30, 2011 1:37 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 3374

Joined: 11th Mar 2008

Ride: EA SVO, AU2 Forte

Location: Bendigo
VIC, Australia

i believe after cruising the Princes Highway on petrol last night. gas mixer removed that it starts to overfuel near idle. making it hunt. i'll get a J3 and see how i go

 

_________________

Daily driver: AU2. 5 speed. 19" FG luxos. Full exhaust. Lowered. AU3 XR leather interior, converted to full power windows. 3.45 LSD. IN THE FUTURE: Tickford 6
Weekend driver: EA SVO AU motor. Built BTR. TCE 2800 stall. T76 turbo. Locked diff. On E85. approx 320rwkw. 11.5 @121mph

Top
 Profile  
 
 
 Post subject: Re: Annoying surge on deceleration
Posted: Sat Apr 30, 2011 6:12 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 4285

Joined: 8th Dec 2004

Gallery: 25 images

Ride: EB2 Ghia,Mighty Boy,Eb1 Xr8 5spd

Location: ** In the Shed! **
VIC, Australia

Around idle that thing smelt way rich, so a J3 to lean the bottom end out wouldn't be a bad thing at all......

Cheers

ToranaGuy

 

_________________

I am the ToranaGuy!|74 Lh Torana Turbo|78 Hz PanelVan|86 Mighty Boy Ute|93 EB2 Ghia,GT Mockup,5spd,LPGI,Full Leather|2 x EB Xr8 5spd's|FS [VIC]: Wrecking - Eb XR8 - Parts available |Build Thread|Ebay Items - Ford Parts|

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 25 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Google [Bot] and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 7:54 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names