Fordmods Logo

AU track car, running overly rich, need direction 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: AU track car, running overly rich, need direction
Posted: Tue Aug 01, 2017 2:44 am 
Getting Side Ways
Offline

Age: 31

Posts: 771

Joined: 20th Nov 2005

Ride: AU XR8 220 Manual

Hi guys.

I have an AU XR6 HP track car. On a recent track day I was shocked by its fuel consumption. Now I am not expecting good fuel consumption on a race car but it used noticeably more than on a previous track day.

It also felt a little flat down low, probably due being over rich.

When I got home it wasn't idling well and I pulled the plugs out. Jet black, covered in dusty soot etc. The car is also spitting black soot from the exhaust (not cat).

The car has a stock HP engine, straight through exhaust, extractors and no cat. Cold air intake with pod and nothing else.

I ran the codes, initially a few came up. However I cleared them and all that came up was the air con and emissions charcoal valve came up (both have been removed).

I cleaned the plugs and the ISC, which helped the idle but still rich.

I also noted that the fans weren't running so I thought maybe the Head temp sensor was out of spec causing it to think it was cold/run rich and not turn on fans. This was perfectly in spec though.

I am looking for any other ideas as to where to go next.
Top
 Profile  
 
 
 Post subject: Re: AU track car, running overly rich, need direction
Posted: Tue Aug 01, 2017 5:13 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11734

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Vacuum leak? MAP sensor working and no split in tube? Check the O2 sensor as well. Is the spark okay?

Make sure the inlet manifold bolts are on tight, mine were coming loose over time when I replaced the gasket, retightened them and they never moved again, same with exhaust manifold.

How are the injectors? Could be dirty and giving poor spray pattern.

Hope that helps and good luck!

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: AU track car, running overly rich, need direction
Posted: Wed Aug 02, 2017 4:37 am 
Getting Side Ways
Offline

Age: 31

Posts: 771

Joined: 20th Nov 2005

Ride: AU XR8 220 Manual

I have tackled a few of those things. Inlet manifold bolts were tightened, I do need to go over it again for vac leaks but nothing obvious.

I will test the o2 sensor tomorrow, just need the specs.

I was hoping that it was the head temp sensor but that was all ok.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 23 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Nov 23, 2017 4:43 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names