Fordmods Logo

BA SR starting issues 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: BA SR starting issues
Posted: Thu Feb 25, 2010 5:04 pm 
Oompa Loompa
Offline

Posts: 41

Joined: 18th Feb 2010

Ride: henry's finest

Location: sydney
NSW, Australia

The missus has a BA SR with 64000km's on it.

Occasionally when started from cold it will stall immediately. This was intermittent until today.
While we were out it did it and the car was warm. Then trying to start it after the intial stalling it took a bit of cranking(4-5secs) to get it to start. It did this 3 times in a row. On the the 3rd time it felt like the starter was struggling to turn the motor.

My initial thoughts are fuel supply. But after hearing the starter struggle I not so sure now.

Apart from this the car runs perfect.

Any ideas/experiences?

Thanks
Top
 Profile  
 
 
 Post subject: Re: BA SR starting issues
Posted: Thu Feb 25, 2010 8:31 pm 
Getting Side Ways
Offline
User avatar

Posts: 670

Joined: 29th Nov 2007

Gallery: 1 images

Location: brisbane
QLD, Australia

my ba does this as well but only when i hit the key and let the key go prematuraly it seems to take while for the fuel pressure to build up (my have somthing to do with my 60pound injectors and walbro fuel pump) also on startup the revs can sit low and almost stall.

 

_________________

if the bar aint bendin your just pretendin

Top
 Profile  
 
 
 Post subject: Re: BA SR starting issues
Posted: Thu Feb 25, 2010 8:44 pm 
Getting Side Ways
Offline
User avatar

Age: 64

Posts: 3448

Joined: 11th Jan 2009

Ride: BA Falcon XT

Location: Smithfield
NSW, Australia

Sounds like you may have either some dirty fuel or, the Fuel Pressure Regulator could be pushing through too much pressure. One of our utes the other day was displaying similar symptoms and the PSI was 510, about 250 more than it should be.
Wouldn't be a bad idea to put a nice new filter on it and maybe run a bottle of injector cleaner in the next full tank.
Top
 Profile  
 
 
 Post subject: Re: BA SR starting issues
Posted: Fri Feb 26, 2010 12:20 am 
Oompa Loompa
Offline

Posts: 41

Joined: 18th Feb 2010

Ride: henry's finest

Location: sydney
NSW, Australia

Thanks guys.

I'll have a squiz at the fuel reg.

I know if you turn the key straight from off to start when cold it runs and stall straight away. Could be not enough pressure in the rail??? I dunno.

$44 to get it diagnosed and its still under warranty so hopefully it'll get fixed for free. I just don't want the stealership giving us the run around.
Top
 Profile  
 
 
 Post subject: Re: BA SR starting issues
Posted: Mon Mar 08, 2010 11:13 pm 
Oompa Loompa
Offline

Posts: 41

Joined: 18th Feb 2010

Ride: henry's finest

Location: sydney
NSW, Australia

Well it got serviced. $230 somehow got stretched to an estimate of just over $900. They were promptly told to stick to the oil and filter and brake fluid change.

Anyway they didn't tell us what was causing the stalling. However the cca of the battery was apparently very low. Over the weekend the issue got worse. So it was decided to try a new battery.

Off to supershyte auto and $150 later we had a new battery.

The standard battery was a 460cca and it was replaced with a 470cca. When started for the first time it almost stalled and idled pretty weak. But wee haven't had the issue return as yet.

So maybe it was a dodgy battery... who knows.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 10:21 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names