Fordmods Logo

BA XR6 Limp mode 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: BA XR6 Limp mode
Posted: Thu Mar 29, 2012 2:32 am 
Parts Gopher
Offline
User avatar

Age: 31

Posts: 93

Joined: 14th May 2011

Gallery: 8 images

Ride: Ford Falcon FG F6

Location: Perth
WA, Australia

This usually happens when I first start the car for the day, the car just about always stalls after a few meters down the road and the engine light comes on, but its a auto. Then I put it in Park turn the engine off and restart and good as new.

What ive noticed is when that happens my temp gauge is very cold at first but when I restart the engine the needle instantly goes up off the cold mark slightly. So I am assuming that the car is not passing its temp check and goes into limp mode.

Are there any problems that could occur if I just let it be?
The car did it before the custom tune so could it be the thermostat?

 

_________________

08 FG F6 #326. 4" Xforce exhaust turbo back with mid muffler delete, 1000cc injectors, 20% Underdrives, Stage 2 intercooler and piping, Stage 2 gear box, Upgraded flex plate, upgraded transcooler, upgraded fuel pump, Streetfighter air intake, cooler thermostate, SCT tune at 20psi at 406rwkw

Top
 Profile  
 
 
 Post subject: Re: BA XR6 Limp mode
Posted: Fri Mar 30, 2012 2:28 am 
Parts Gopher
Offline
User avatar

Age: 31

Posts: 93

Joined: 14th May 2011

Gallery: 8 images

Ride: Ford Falcon FG F6

Location: Perth
WA, Australia

Yea good call!!

 

_________________

08 FG F6 #326. 4" Xforce exhaust turbo back with mid muffler delete, 1000cc injectors, 20% Underdrives, Stage 2 intercooler and piping, Stage 2 gear box, Upgraded flex plate, upgraded transcooler, upgraded fuel pump, Streetfighter air intake, cooler thermostate, SCT tune at 20psi at 406rwkw

Top
 Profile  
 
 
 Post subject: Re: BA XR6 Limp mode
Posted: Sat Apr 14, 2012 1:21 pm 
Fordmods Newbie
Offline

Age: 59

Posts: 5

Joined: 4th May 2010

Ride: ford ba xr6 ute

Location: nowra
NSW, Australia

hi i have had the same problem , took it to my local ford dealer , found out it was the TPS throttle position sencsor. new one in no problems .
Top
 Profile  
 
 
 Post subject: Re: BA XR6 Limp mode
Posted: Sat Apr 14, 2012 7:31 pm 
Parts Gopher
Offline
User avatar

Age: 31

Posts: 93

Joined: 14th May 2011

Gallery: 8 images

Ride: Ford Falcon FG F6

Location: Perth
WA, Australia

Yea I've heard from some where it might of been on here that someone else had similar problems like you and I and he suggested that it could be the TPS. Any idea of how much a TPS usually goes for and is it hard to install?

 

_________________

08 FG F6 #326. 4" Xforce exhaust turbo back with mid muffler delete, 1000cc injectors, 20% Underdrives, Stage 2 intercooler and piping, Stage 2 gear box, Upgraded flex plate, upgraded transcooler, upgraded fuel pump, Streetfighter air intake, cooler thermostate, SCT tune at 20psi at 406rwkw

Top
 Profile  
 
 
 Post subject: Re: BA XR6 Limp mode
Posted: Sun Jun 10, 2012 5:51 pm 
Fordmods Newbie
Offline

Age: 59

Posts: 5

Joined: 4th May 2010

Ride: ford ba xr6 ute

Location: nowra
NSW, Australia

Mr. Xpressionz wrote:
Yea I've heard from some where it might of been on here that someone else had similar problems like you and I and he suggested that it could be the TPS. Any idea of how much a TPS usually goes for and is it hard to install?

hi did you get the tps fixed .they are not to hard to put in
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 11:38 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names