Fordmods Logo

BA XR6 not starting. 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: BA XR6 not starting.
Posted: Tue May 05, 2015 1:28 pm 
Fordmods Newbie
Offline

Age: 35

Posts: 1

Joined: 5th May 2015

Ride: 2003 Ba XR6

Location: caboolture south
QLD, Australia

In the recent floods in caboolture my engine bay got a bit wet. when i tried starting it smoke and noise came from engine bay and when i try to start it now all it does is tick repeatedly. I can't see any wires burnt or loose. Please help. Im not a mechanical person so dumb it down for me please.
Top
 Profile  
 
 
 Post subject: Re: BA XR6 not starting.
Posted: Tue May 05, 2015 10:29 pm 
Fordmods Newbie
Offline

Age: 24

Posts: 12

Joined: 3rd May 2015

Ride: FPV Fairmont

Location: Kempsey
NSW, Australia

The reason for it not starting is caus its full of water. To fix it disconnect the battery and let it sit for a few days to dry out.

 

_________________

2003 FPV enhanced Fairmont = 250kw at the wheels and still tuning.
Ford = First On Race Day

Top
 Profile  
 
 
 Post subject: Re: BA XR6 not starting.
Posted: Sun May 10, 2015 11:30 pm 
Technical Contributor
Offline

Posts: 492

Joined: 13th Jul 2013

Location: Campbelltown
NSW, Australia

how deep - cylinders may be full of water(as well as other things) -pull plugs and crank over ?
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 12:02 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names