Fordmods Logo

Battery light on 

 

Page 1 of 2 [ 21 posts ] Go to page 1, 2  Next

 
 Post subject: Battery light on
Posted: Fri Sep 22, 2006 12:23 am 
Parts Gopher
Offline
User avatar

Age: 36

Posts: 73

Joined: 3rd Mar 2005

Gallery: 4 images

Ride: BF falcon Mk1

Location: gold coast
QLD, Australia

so today i was driving home and noticed the car was a bit rough, after paying a bit more attention i saw the battery light was lit on the dash, it went out after about 2 minutes so i didnt think much of it, anyways later this arvo i was driving and i came back on, i check the belt and it was still intact, all wires look connected still and the car was still running even when i turned it off and back on again.
anyeways after about 1/2 hr of still driving the car lost all power, was coughing and spluttering and firing really bad, i pulled over and check the motor still cant see anything wrong, now it wont start at all flat battery i think.............. anyone got any idea's why it could just suddenly die, shoudl i go get a new alternator maybe????
Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 12:28 am 
Getting Side Ways
Offline

Age: 31

Posts: 3893

Joined: 15th Nov 2004

Gallery: 24 images

Ride: BF MKII V8 Fairmont Ghia

Location: Perth
WA, Australia

id get a new battery before a new alternator.


batterys have a tendency to suddely die.

 

_________________

2007 Steel BF Ghia MKII V8 - 19" GTP's + Superlows

Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 12:36 am 
Parts Gopher
Offline
User avatar

Age: 36

Posts: 73

Joined: 3rd Mar 2005

Gallery: 4 images

Ride: BF falcon Mk1

Location: gold coast
QLD, Australia

battery is only 2 months old, i'll try it though in the morning, cheers
Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 12:36 am 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 3097

Joined: 5th Nov 2004

Gallery: 29 images

Ride: VU SS

Location: Ivanhoe
NSW, Australia

Nah, I would think alternator. Once a car is running it doesn't even use the battery really.

 

_________________

EF Fairmont now Sold!
Guides: Polishing|Modifications |Manual Conversion

Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 12:37 am 
Technical Contributor
Offline
User avatar

Age: 32

Posts: 2517

Joined: 7th Nov 2004

Gallery: 4 images

Ride: LS3 VF

Location: Bunbury
WA, Australia

heres an interesting point that wont apply to this topic specifically.
BA/BF (and possibly AU, im not sure) control the voltage reg in the alternator by the pcm
Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 12:59 am 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 11103

Joined: 15th Nov 2004

Ride: AU III XR8 Pursuit 250 ute

Location: Hobart
TAS, Australia

Alternators prolly gone. I drove my car around for 3 days with that light on once...

 

_________________

Heaps of performance EF/L parts for sale, including supercharged VCT motor!

2002 Ford AU Series III Falcon XR8 Pursuit 250 ute - 5.6L of V8 Windsor!

Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 1:22 am 
Getting Side Ways
Offline

Posts: 404

Joined: 8th Jun 2006

Location: melbourne
VIC, Australia

Try recharging the battery. If you can, then start the car then check the voltage across the battery with a multimeter or get an auto elec to do it. It should be around 13.8v at around approx 1500rpm. If the voltage is much lower, especially if it is under 12v, then it is your alternater. If you cant recharge your battery then replace it first.
Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 12:26 pm 
Parts Gopher
Offline
User avatar

Age: 36

Posts: 73

Joined: 3rd Mar 2005

Gallery: 4 images

Ride: BF falcon Mk1

Location: gold coast
QLD, Australia

does anyone know if an alternator from an xf, will fit in the EA???? i got one here but i think its a different plug connection to the ea.
Top
 Profile  
 
 
Posted: Fri Sep 22, 2006 2:30 pm 
Smokin em up
Offline
User avatar

Age: 33

Posts: 291

Joined: 5th Nov 2004

Ride: EL GT - T2 TS50

Location: Cairns
QLD, Australia

it will be an alternator issue, more than likely the brushes, can puckup new brushes from an auto elec fairly cheap, thats what i would be replacing first, you will obviously also need to charge up your battery.
Top
 Profile  
 
 
Posted: Sat Sep 23, 2006 11:25 pm 
Stock as a Rock
Offline

Age: 38

Posts: 102

Joined: 16th Aug 2006

Gallery: 3 images

Location: Adelaide
SA, Australia

If it was the battery it wouldnt make the car misfire like your saying. The alternator would be the first place to start i think.

 

_________________

95 EF Gli, EF XR6 Motor & Comp, Lowered 2", Koni & Kmac Suspension setup, Gold ROH ZS SP Wheels, trip comp, Pioneer Head Unit, speakers & 12 stacker, 2 1/2" Exhaust, Hi Flow Cat Convertor, Extractors.

Top
 Profile  
 
 
Posted: Sat Sep 23, 2006 11:34 pm 
Getting Side Ways
Offline
User avatar

Posts: 887

Joined: 8th Aug 2006

Ride: Falcon

Location: Central Highlands
QLD, Australia

Want model EA have you got if it's a pre 1990 model without tibbe locks then you will have a bosch alternator and the voltage regulator is at the back with 2 screws holding it in.

I would say the 2 bushes on the voltage regulator are worn right down and that's whats causing the light to come on.

Just pull it out and check to see if there is any meat left on the 2 bushes. There rectangular in shape and hold in by a spring, about 2cm long.

cheers.............

 

_________________

97 EL Fairmont 4l OHC .Silver.
Exhaust: Pacemaker's, 2.5" exhaust and Hiflow cat
Intake: FRAM AIRHOG , EL GT snorkel
XR6 300kpa fuel reg Stg 2 Auto Shift Kit.6DJA ECU
PM in Qld looking too buy Toyota 4*4 SR5 Dualcab Hilux 91-97 with 2.8l diesel engine/5spd manual

Top
 Profile  
 
 
Posted: Sat Sep 23, 2006 11:39 pm 
Stock as a Rock
Offline
User avatar

Posts: 158

Joined: 23rd Sep 2006

Ride: '84 Zk Fairlane

Location: Wodonga
VIC, Australia

dust off a multimeter and check that the alternator is chargering the brushes could be worn out and be makeing poor/no contact at all and the light would pop up for this reason

 

_________________

ZK Fairlane Project Thread:
http://www.xfords.com/forum/showthread.php?t=2923

Image

Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 3:28 pm 
Getting Side Ways
Offline
User avatar

Age: 34

Posts: 10826

Joined: 17th Apr 2005

Gallery: 34 images

Ride: BF MK11 XR 6 TURBO ZF 6spd

Power: 225 rwkw

Location: glenwood/sydney
NSW, Australia

my car is doing that stuff too... reading only 12 volts on the guage then after 5-10mins reading more like 14.4 vollts then occasionaly spiking up to just under 16 volts!! -with the needles in the dash going up and down crazy and my headlights pulsing brighter..along with all the other little lights in the dash.. my alternator is only 2 months old reco'ed..

 

_________________

Todd: Nurse, suction.
Nurse: The patient's not even here yet.
Todd: I know.

http://www.youtube.com/watch?v=_GQpRYRcAiA

Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 3:37 pm 
Parts Gopher
Offline
User avatar

Age: 36

Posts: 73

Joined: 3rd Mar 2005

Gallery: 4 images

Ride: BF falcon Mk1

Location: gold coast
QLD, Australia

well just thought i'd fill everyone on what happened...........so the next day i went to the wreckers and got a new alternator ($60), drove all the way into the city to get the car which i had left at a servo, asked the guy there if it was cool and he said yeah, i drive into the servo and the car isnt there.
turns out the chcik working there that morning wantedto park her car in the spot where mt car was left and called a tow truck which came and took it away to the depot, now they want $400 to get it out plus $25 for each day its in there. i was soooooo freaking p****d off, there were no tow away signs where i left the car and the guy said it would be safe.
i'm not paying the bill and have rang a lawer to get it sorted out, went and took photo's of where it was and there is clearly no signs saying it would be towed. After i spoke to the chick again i said where are the signs and she told me the sign had fallen down that night andthey hadnt gotten around to putting it back up :(

i'll keep everyone updated to let you's know how it goes in court LOL
thanks heaps for the help guys
Top
 Profile  
 
 
Posted: Sun Sep 24, 2006 8:47 pm 
Stock as a Rock
Offline
User avatar

Posts: 100

Joined: 18th Nov 2004

Ride: turbo

Location: melb
VIC, Australia

sounds like alternator
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 21 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 28 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 8:14 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names