Fordmods Logo

BF cruise control will not set 


Page 1 of 1 [ 1 post ] 

 Post subject: BF cruise control will not set
Posted: Sat Aug 30, 2014 2:39 am 
Fordmods Newbie

Age: 28

Posts: 2

Joined: 19th Mar 2014

Ride: Ford Falcon

Location: Melbourne
VIC, Australia

Well I have had this issue since buying the car in Feb, the boys over at FF are trying to help me out but to no avail so hoping for some more ideas here. Basically the cruise will not set....Things I have done.....

1) Reset all brake and clutch switches
2) Changed all pedal switches
3) OHM tested cruise buttons and the resistances were a little low
4) Replaced steering wheel buttons
5) Checked brake light globes, all fine

I am at a loss short of trying a new BEM, I've tried pulling on the back of the pedals when driving and seeing if it sets, pressing all buttons(set, coast etc)....Only thing I can think to mention is the brake lights will not come on with really light braking, I have to apply a decent bit of force for them to come on as opposed to my old BF sedan, if I just rubbed my foot on the brake pedal the lights would come on..

Its a 2007 BF Ripcurl ute in 5spd manual, would love a solution or an idea to keep trying!!!!
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 25 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 28, 2016 3:57 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names