Fordmods Logo

car stalling when put in neutral 


Page 1 of 1 [ 1 post ] 

 Post subject: car stalling when put in neutral
Posted: Tue Jun 17, 2008 12:50 pm 
Getting Side Ways

Age: 29

Posts: 1087

Joined: 1st Sep 2007

Ride: '07 LT XR5

Power: 133 rwkw

Location: sydney
NSW, Australia

Hi guys,
I have had an issue for a while where my 5spd XR6 would stall when it was knocked into neutral.

ie: doing 80kp/h in 5th, see lights turning red, knock into neutral, brown stains in pants as i forget to kick the throttle to keep it going, it stalls...

now i knwo someone else posted a similar issue (but with an auto) and i THINK i've found the fix after doing the usual checks on timing, sparks, leads, filters x eleventy.

power steering fluid.. yup humble ps fluid. Now i know i've had a leaking p/s pump for quite some time, but i kinda forgot about it and noticed the stalling getting absolutely ridiculous (read: no such thing as self idle).

Finally the pump started having a whinge at me this morning, a massive whinge. put some new fluid in her and no more whinging and... no more stalling!!!

so just another thing for people to think about it they have similar issues check your power steering fluid level



So much RAM the motherboard twisted off the POST.

I lost 3 cylinders... but gained a turbo...
Proud owner of an '07 XR5Turbo

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 26 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 21, 2016 10:57 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names