Fordmods Logo

Cooling problem with EL 

 

Page 1 of 1 [ 13 posts ] 

 
 Post subject: Cooling problem with EL
Posted: Thu Jan 16, 2014 4:58 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 552

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Brisbane
QLD, Australia

hey guys just recently did an au conversion in my EL xr6 only the bottom end tho. the motor was out for a fair while. while I gather the cash to get it all back together but now ive notice I have cooling problem with it mostly in these last couple of days while it been hot. so ive had the air con on most of the time while driving it and the temp gauge sits pretty much near the H. so im gonna replace the thermostat and see how that goes but should I be looking at anything else to solve this cooling problem?

 

 

Attachments:
temp gauge.jpg
temp gauge.jpg [ 58.94 KiB | Viewed 31 times ]
Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 5:10 pm 
Parts Gopher
Offline
User avatar

Age: 47

Posts: 92

Joined: 8th Apr 2012

Ride: EA Falcon S 30th Anniversary

Location: Brisbane
QLD, Australia

I would undo the radiator mounts and tilt it back to see if the gap between the AC condenser and the radiator is full of gunk. Otherwise maybe the radiator itself is gunked up in the bottom rows. My EA had both of these issues so I cleaned it all out and fitted a heavy duty radiator. Failing that did you check the water pump impellor when you put in the bottom engine?

 

_________________

1991 EA2 Ford Falcon S Sedan
LeMans Red - 30th Anniversary 3.9 MPFI Manual LSD

1996 XH Ford Falcon Outback Ute
LeMans Red 4.0 Auto

Originality saves our history.

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 5:18 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 552

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Brisbane
QLD, Australia

I just left the one already attach to the front of the au block but I do have my old water pump sitting in the shed or I might just buy a new if it is the water pump. do I need to buy some coolant flush or can i just use straight water to flush the system out
Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 5:24 pm 
Parts Gopher
Offline
User avatar

Age: 47

Posts: 92

Joined: 8th Apr 2012

Ride: EA Falcon S 30th Anniversary

Location: Brisbane
QLD, Australia

I tried the chemical flush from the car parts store but it only partially fixed the problem. Given the idea of do easiest thing first I'd check the gunk between condensor and radiator first, then radiator flush, and lastly the water pump. Like I said mine was good until very hot weather and the main issue was the crap between the two heat exchangers. I could also tell my radiator was bad when I pulled it out, the bottom was noticeably heavier which suggested it had a fair bit of sediment etc.

 

_________________

1991 EA2 Ford Falcon S Sedan
LeMans Red - 30th Anniversary 3.9 MPFI Manual LSD

1996 XH Ford Falcon Outback Ute
LeMans Red 4.0 Auto

Originality saves our history.

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 5:57 pm 
Getting Side Ways
Offline

Age: 21

Posts: 462

Joined: 24th Jun 2013

Gallery: 3 images

Ride: Ford Fairlane na2

Location: Launceston
TAS, Australia

Don't know if this helps but my fairlane had the same problem with over heating so i changed the water pump nothing, the thermostat got worse, got a genuine ford thermostat back to the same as before, changed the temp sender nothing, changed all the hoses gotmabit better then i decided to change the radiator and it was fixed.

 

_________________

NA2 fairlane - 3.9 with au headgasket & injectors, ef fans, 2.5" zorst, lowered on selby springs , kenwood head unit and 6 speakers, fusion sub, el ecu & ti chip

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 7:25 pm 
Getting Side Ways
Offline
User avatar

Age: 23

Posts: 461

Joined: 31st Mar 2013

Ride: 96 EL XR6

Location: Hervey Bay
QLD, Australia

Renew everything and you wont have a drama.. new radiator, hoses, thermostat, blow condensor out with compressed air while radiator is out, and flush block till you think youve put your water bill thru the roof :wink:

I done this to mine as soon as i got it, temp guage now doesnt get over L in "Normal" which by the cluster in diag mode is 82-89degree. Just fluctuates between the the Line and "L".

 

_________________

EL XR6, T5 Speed - Full Factory Fitted Tickford Body Kit, AU Engine, Billet Camtech 845 Cam, J3 Chip, MLS Gasket, Intake, Extractors, High flow cat, 2 1/2in exhaust, K&N Air Filter, 3.45 LSD, - My Pride and Joy

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 7:29 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1110

Joined: 27th Dec 2011

Gallery: 6 images

Ride: ef falcon futura

Power: 154 rwkw

Location: Koo Wee Rup
VIC, Australia

as Falcon96XR6 said, replace it all, usually when one thing goes, the next isnt far behind anyway

 

_________________

ef futura, pacemakers, 2.5inch catback, k&n panel filter and 3.45 lsd. extractors/cat, ticky head, custom cam grind, t5. now onto cosmetics.

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 7:58 pm 
Parts Gopher
Offline
User avatar

Age: 47

Posts: 92

Joined: 8th Apr 2012

Ride: EA Falcon S 30th Anniversary

Location: Brisbane
QLD, Australia

The old E-series shotgun approach. haha.

I fitted the Repco heavy duty radiator (noticeably thicker than the standard unit) and shortly after we had 43 degrees in western NSW and I had A/C running full tilt car ran perfect even up to 120-130 cruise, and overtaking no issues. I also replaced the A/C condenser as many fins were bent etc on the old one. Repco has these for earlier Falcons at the moment around $40 on clearance of jayair items.

 

_________________

1991 EA2 Ford Falcon S Sedan
LeMans Red - 30th Anniversary 3.9 MPFI Manual LSD

1996 XH Ford Falcon Outback Ute
LeMans Red 4.0 Auto

Originality saves our history.

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Thu Jan 16, 2014 8:51 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 552

Joined: 3rd Oct 2006

Ride: EL XR-6

Location: Brisbane
QLD, Australia

thanks for the replies guys ill give it full flush out on the weekend ill let u know how I go.
Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Fri Jan 17, 2014 6:59 am 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

Make sure the Fans run on Hi, a few EL's only run on Low.

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Fri Jan 17, 2014 4:19 pm 
Getting Side Ways
Offline

Age: 21

Posts: 462

Joined: 24th Jun 2013

Gallery: 3 images

Ride: Ford Fairlane na2

Location: Launceston
TAS, Australia

you could also set your fans up so one runs at one temp and the other runs when it gets hotter.

 

_________________

NA2 fairlane - 3.9 with au headgasket & injectors, ef fans, 2.5" zorst, lowered on selby springs , kenwood head unit and 6 speakers, fusion sub, el ecu & ti chip

Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Fri Jan 17, 2014 4:54 pm 
Stock as a Rock
Offline

Age: 27

Posts: 199

Joined: 27th Jun 2008

Gallery: 9 images

Ride: EF 2 Fairmont. AU 5 Litre ute

Location: Berwick
VIC, Australia

My au was running warmer than it norally does, canged the thermostat and its heaps better. Like everyone else has sayed flush the radiator. Put in new thermostat and maybe a new cap
Top
 Profile  
 
 
 Post subject: Re: Cooling problem with EL
Posted: Fri Jan 17, 2014 6:02 pm 
Getting Side Ways
Offline

Age: 21

Posts: 462

Joined: 24th Jun 2013

Gallery: 3 images

Ride: Ford Fairlane na2

Location: Launceston
TAS, Australia

flushing is the main thing but a new cap can help abit.

 

_________________

NA2 fairlane - 3.9 with au headgasket & injectors, ef fans, 2.5" zorst, lowered on selby springs , kenwood head unit and 6 speakers, fusion sub, el ecu & ti chip

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 13 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 36 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 2:21 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names