Fordmods Logo

CRUISE CONTROL MALFUNCTION 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: CRUISE CONTROL MALFUNCTION
Posted: Tue Mar 29, 2011 9:50 am 
Oompa Loompa
Offline

Age: 27

Posts: 35

Joined: 19th May 2010

Ride: Ford NCII Fairlane 1994

Location: Sydney
NSW, Australia

Hi guys, here i have my NC2 FAIRLANE with a cruise control problem. The cruise control indication light (below the car display on the dash) always stays ON!
1. I have inspected the switch on the steering wheel, disconnected it & it still stays ON.
2. I've inspected the vacuum pump & relay, all connections seem ok.
3. I also took a look at the ECU for this system which is aka the "Speedo Control Unit" - located under the centre console. Upon disconnecting it the indication light turns OFF.

If anyone has had a similar problem i would be glad to see their outcome! Thanks & sorry for the long story! Lol
Top
 Profile  
 
 
 Post subject: Re: CRUISE CONTROL MALFUNCTION
Posted: Thu Mar 31, 2011 5:26 pm 
Oompa Loompa
Offline

Age: 27

Posts: 35

Joined: 19th May 2010

Ride: Ford NCII Fairlane 1994

Location: Sydney
NSW, Australia

Fixed the problem!!

If your brake light (Stop Lamp) Fuse is blown, the "Cruise Control On" indication light alluminates & stays on.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: Google Adsense [Bot] and 31 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Dec 18, 2017 8:35 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names