Fordmods Logo

Damn cars!!!! 

 

Page 1 of 3 [ 41 posts ] Go to page 1, 2, 3  Next

 
 Post subject: Damn cars!!!!
Posted: Mon Jun 20, 2005 3:01 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Grr just went to take the XR for a drive and the bastard decides it doesnt want to start now....!!! :evil: Not happy, looks like ive gotta go buy a fkn battery now!! It better be just a stuffed battery, its weird all the dials etc and dash lights come up but the car wont turn over!!! :roll:

Hmm its first time thats eva happened... :?

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 3:04 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

Interior light bulb still working ?

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 3:08 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Naa i took the interior light bulb out.. it stayed on after you shut the doors apparently it has a time dely but mine just stayed on, so i took that bulb out... No other lights were on as far as i know.... i havent driven it since saturday so mabe the battery just died on me... It has been raining pretty heavily here as well :roll:

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Last edited by XRFan101 on Mon Jun 20, 2005 3:09 pm, edited 1 time in total.

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 3:09 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

EF/EL's with smartlock arent supposed to start with no interior bulb !

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 3:12 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Dellboy999 wrote:
EF/EL's with smartlock arent supposed to start with no interior bulb !


Huh? you mean the bulb in dome thingy? That thing was working for about 3 weeks when i first bought he car.. Then it just stayed on all the time after that.. and the same with the light near the ignition as well.. took that little bugger out too.

Its gotta be a flat battery as it attempts to turn over but nothing happens.. :roll: Im gonna try and jump start it later on but im open to suggestions, mabe i should just go buy a new battery now...

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 3:13 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

Put the bulb back in, if it doesnt still start then maybe assume battery.

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
 Post subject: Re: Damn cars!!!!
Posted: Mon Jun 20, 2005 3:27 pm 
Getting Side Ways
Offline

Age: 36

Posts: 7287

Joined: 5th Nov 2004

Gallery: 12 images

Ride: 1994 ED XR8 Sprint

Location: Somewhere in
QLD, Australia

XRFan101 wrote:
Grr just went to take the XR for a drive and the bastard decides it doesnt want to start now....!!! :evil: Not happy, looks like ive gotta go buy a fkn battery now!! It better be just a stuffed battery, its weird all the dials etc and dash lights come up but the car wont turn over!!! :roll:

Hmm its first time thats eva happened... :?

just cos the all the lights and s**t come on doesnt mean there's enough left in the battery to start the engine

 

_________________

Banned

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 3:29 pm 
Getting Side Ways
Offline

Age: 32

Posts: 972

Joined: 6th Feb 2005

Gallery: 6 images

Ride: XHII pano, Landau

Location: S.E Subs
VIC, Australia

Sometimes when u f**k around with wiring or i found taking my interior bulb out you blow a fuse, cant remember the name of it but i found it happened with mine, changed the fuse and it started. I think if i remeber correctly the radio wasnt working either when it blew.........just something to check if jumpstarting doesnt work

 

_________________

Automatics only come in assult riffles
---------------------------------------
www.aussiecoupes.net

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 3:32 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

So you say put the bulb back in? Okay i just checked the car again and i suspect its more than a flat battery... Ive just posted some pics too. um i checked everything again, thiers no low battery warning light coming up either.... And my highbeams and lights are working also :? But car just doesnt seem to have enough power to turn over.... Ahh possibly a stuffed starter motor?

i dont know :?

HELP

So replace the globe in that pic then? i will see if i can find one first lol.

 

 

Attachments:
P1220009.jpg
P1220009.jpg [ 122.63 KiB | Viewed 28 times ]
P1220008.jpg
P1220008.jpg [ 107.69 KiB | Viewed 22 times ]

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 4:31 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Okay battery was flat... I suspect thou that the battery itself may be on its way out... If it goes flat on me again either thiers something draining the power while the cars off or the battery is fked! :roll: taking test drive now, then i will shut the car down and see if it fires up again!

Thanks for the replys and help.. hopefully all goes well now :)

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 4:35 pm 
Getting Side Ways
Offline
User avatar

Age: 46

Posts: 1040

Joined: 5th Nov 2004

Gallery: 5 images

Ride: EA Fairmont Ghia

Location: Melbourne
VIC, Australia

If the bulb in the car and the ign light stayed on, you checked the boot light as well ?

You must have a bad wire somewhere earthing out anyway, I would suggest look at changing the BEM to fix the lights staying on problem.

 

_________________

Full working BA Shifter now upgraded to BF Shifter.
BA headlight inserts in my EA headlights.

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 4:58 pm 
Getting Side Ways
Offline
User avatar

Age: 36

Posts: 8655

Joined: 5th Nov 2004

Gallery: 37 images

Ride: V8 EF Futura

Location: Adelaide CBD
SA, Australia

Andrew, does the interior light stay on after you've started the car? BTW you dont need the interior globe to run the engine.. not on my EF anyways.

Does it go off after 60minutes or so?

Maybe one of the door switches is not working?

Check the electrolyte levels in the battery... if they are too low then the battery will basically never be the same again.... but you can still top up with distilled water.

Sprint auto parts sells a 520CCA which is perfect for these cars, about $105...

 

_________________

I promise..... I will never die.

Fordmods Administration Group MINOR PUNKED

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 5:48 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 2833

Joined: 7th Nov 2004

Gallery: 4 images

Ride: Lincoln LS, MKII Escort, ED

Location: geelong
VIC, Australia

my car (about every four months) decides it wont start, EVERY time its the stupid battery terminal corroding, a coupla times ive caught it before it gets bad enough to let the battery go flat,

 

_________________

Because i can.

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 6:14 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Okay yeah that interior globe that i took out is the one that is supposed to go out after 60 seconds when you lock the car etc also same with the ignition globes as well, now when i first purchased the car 12 months ago it worked fine, thier was not one fault with the electronics. Until both of the globes i just stated died on me so i took them out and never worried about them b4....

Since then i never had ne problems with starting the car up until now... :roll:

So you suggest getting one of the volt meter testers or whateva you call it and find out where the bad wiring is? I dont have one of them myself but i might just buy one ne way... Might have a good look once the weather clears up down here.

Thanks for all the suggestions, the battery terminals were fine and had been previously treated to and the battery was filled up as well so... I dunno? im not sure about the boot light thou.. i will check that out as well.

Im not very car BEM smart wise so it may take a while for me to work out what im looking for lol.. :roll:

Thanks for the help thou i muchly appreciate it!

Andrew

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
 
Posted: Mon Jun 20, 2005 6:51 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 3885

Joined: 6th Nov 2004

Gallery: 24 images

Ride: BF MKII XR6 Turbo

Location: Victor Harbor
SA, Australia

Okay 2+ hours since driving it, started the car and it fired up straight away. Im gonna check it again in a few more hours but i suspect that the battery is fine...for now. Im going to the city on wednesday so i might 'try' and find a decent battery for a discount lol. (lots of end of financial year sales atm) :)

I will keep yas posted, oh btw the boot light is fine, doesnt seem to stay on when the boots closed so it cant be that :)

 

_________________

Image -BF MKII XR6 Turbo in EGO-

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 3  [ 41 posts ]  Go to page 1, 2, 3  Next

Who is online

Users browsing this forum: No registered users and 34 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 9:39 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names