Fordmods Logo

Ea heater problems 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: Ea heater problems
Posted: Thu Jun 30, 2005 6:42 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1126

Joined: 5th Nov 2004

Gallery: 13 images

Ride: Falcon

Location: Melbourne
VIC, Australia

I have 2 ea's and they are both doing the same thing, turn the heater on anything past 1 or 2 and you get cold air, with the fan on low you get some warm air but nowhere near enough, is this a common problem, what could be wrong?
thanks

 

_________________

Succesful trades with bentles_eb, Pane, chunkz, xr8_dismantler, OBS35N, mrnasty, Steady ED, voxace, Mash85, ovo616, ef biff, lukey, dazza2924, Seannyb, gunit18, jkk, Tocchi,

Top
 Profile  
 
 
 Post subject: Re: Ea heater problems
Posted: Thu Jun 30, 2005 8:36 pm 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

Felony wrote:
I have 2 ea's and they are both doing the same thing, turn the heater on anything past 1 or 2 and you get cold air, with the fan on low you get some warm air but nowhere near enough, is this a common problem, what could be wrong?
thanks


Sounds like the heater core isn't getting hot enough. Blocked core, blend door not working or faulty heater tap.

Also does the engine run at the right temp?

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Thu Jun 30, 2005 9:26 pm 
Getting Side Ways
Offline
User avatar

Age: 35

Posts: 1126

Joined: 5th Nov 2004

Gallery: 13 images

Ride: Falcon

Location: Melbourne
VIC, Australia

Ea fairmont runs very cool, usuallay a 1/3 and below on the temp gauge, and the falcon s gets up to just about half or a bit over if i give it a bit,
cheers

 

_________________

Succesful trades with bentles_eb, Pane, chunkz, xr8_dismantler, OBS35N, mrnasty, Steady ED, voxace, Mash85, ovo616, ef biff, lukey, dazza2924, Seannyb, gunit18, jkk, Tocchi,

Top
 Profile  
 
 
Posted: Thu Jun 30, 2005 11:41 pm 
Stock as a Rock
Offline

Age: 31

Posts: 153

Joined: 28th Apr 2005

Gallery: 4 images

Ride: EA Falcon Hybrid

Location: geelong
VIC, Australia

ive got the same problem with my ea the engine temp never goes past half ( just changed the thermostat ) and if the heater is on with the fan up high the hot air turn to cold. dont know whats causeing it probably the heater core i would say. let you know when i change mine.

 

_________________

<<<DAN's CARS>>>
* 88 EA Falcon X2
* 81 FJ40
* 73 KE26 X2
* 73 KE20 x2
* 69 KE10 X2
and more

Top
 Profile  
 
 
Posted: Fri Jul 01, 2005 10:33 am 
Getting Side Ways
Offline
User avatar

Age: 54

Posts: 4102

Joined: 18th Nov 2004

Gallery: 10 images

Ride: PX2 Ranger 4x4 XLT Dual CAB

Location: Carrum Downs
VIC, Australia

polish'd wrote:
ive got the same problem with my ea the engine temp never goes past half ( just changed the thermostat ) and if the heater is on with the fan up high the hot air turn to cold. dont know whats causeing it probably the heater core i would say. let you know when i change mine.


Try flushing it first. I did mine a couple of months ago, heater works great now. might save you a heap of money, & time

 

_________________

Image
She's meanness put to music and the b**ch is born to run!
Like the sign says, "speed's just a question of money. How fast can you go?"

Top
 Profile  
 
 
Posted: Sat Jul 02, 2005 7:02 pm 
Smokin em up
Offline
User avatar

Age: 54

Posts: 209

Joined: 5th Dec 2004

Gallery: 8 images

Ride: 1992 EB II Falcon

Location: Nambour
QLD, Australia

I flushed out the heater core earlier this year when I replaced the tap on my car because I had no heat at all for quite some time due to a jammed heater tap, I also replaced the heater hoses as well.

 

_________________

I drive & I vote....Scrap the fuel excise now.

[FoMoCo] The only fake white ED (That I know of on the Sunshine Coast.)

See more pictures of my car on

http://www.fordgallery.com/showgallery. ... user/14869

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 32 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sun Dec 17, 2017 3:51 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names