Fordmods Logo

EB Acting strangely 


Page 2 of 2 [ 18 posts ] Go to page Previous  1, 2

Posted: Mon Nov 08, 2004 8:06 pm 
Fordmods Newbie

Posts: 3

Joined: 8th Nov 2004

Location: canberra
ACT, Australia

Hmm - a bad week for EBs I reckon.

I'm having similar probs, except...

1. On LPG it's fine.
2. On Petrol it surges a bit at constant speed, and
3. On Petrol it hates idling at operating temp (this is the big worry). Cold is fine, A/C makes no difference. just idling at temp on ULP.

Anyone got any suggestions? Somebody suggested I check the fuel filter, but I'd have thought the temperature wouldn't make any difference in that case. :?: :?: :?:
Posted: Mon Nov 08, 2004 9:53 pm 
Fordmods Newbie

Posts: 8

Joined: 6th Nov 2004

Ride: 92 EB I

Location: Melbourne
VIC, Australia

Same problem's happened in my EB, it actually stalled on me a few weeks back. Hasn't happened since though.. :shock: .. not sure what the problem was but it seemed fine. It sounded strange from the start up, but I didn't think anything of it, but then it spluttered a bit, rough idling and then stalled.
it's probably a bad period of time for EB's..



It's a pleasure to be soaring with the Falcons...

Posted: Wed Nov 10, 2004 6:45 pm 
Stock as a Rock
User avatar

Age: 31

Posts: 131

Joined: 5th Nov 2004

Gallery: 5 images

Ride: AU Forté Pursuit, EB Fairmon

Location: Melbourne
VIC, Australia

took it to the mechanic....he said it defiantely the leads...lead number 2 is misfiring and is really weak. He laughed wen i asked him to change the leads for me....LoL he'll do it...but he reckons its one of the hardest cars to change the leads on. ah well...will be back n runnign smooth again...too bad bout my tranny :(
Display posts from previous:
Sort by  
 Page 2 of 2  [ 18 posts ]  Go to page Previous  1, 2

Who is online

Users browsing this forum: No registered users and 15 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Tue Oct 25, 2016 1:19 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names