Fordmods Logo

EB Low Oil Pressure. 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: EB Low Oil Pressure.
Posted: Sun Dec 24, 2006 1:40 pm 
Stock as a Rock
Offline
User avatar

Posts: 190

Joined: 30th May 2006

Location: Third Rock From The Sun
Oustide Australia

The low oil pressure warning light is staying on when the engine is started it glows bright then goes dull but doesn't extinguish completely, I'm hoping this may just be the sender unit not sure.

 

_________________

God save Allan Moffat, God bless d**k-Johnson and thank Christ for Marcos Ambrose.........

Top
 Profile  
 
 
Posted: Sun Dec 24, 2006 8:03 pm 
Stock as a Rock
Offline
User avatar

Age: 33

Posts: 181

Joined: 27th Nov 2004

Ride: Cortina TE

Location: Perth
WA, Australia

obvious question... (hope u already checked)

is theyre enuf oil in your sump

when motor is off. pull out.. wipe it with a rag.. drop it back in and then pull out agen and see where it is according to your guage on the stick.

if its below Empty mark.. thats the simple solution.

otherwise your oil pump could be blocked and not enuf oil going to the motor. thus causing the sender to say its low.. or the sender could be broken.

 

_________________

Image

Top
 Profile  
 
 
Posted: Sun Dec 24, 2006 8:20 pm 
Getting Side Ways
Offline
User avatar

Age: 31

Posts: 2449

Joined: 5th Nov 2004

Ride: Falcon EB-s

Location: Manjimup
WA, Australia

How long since the oil filter was replaced?

 

_________________

The problem with America is stupidity. I'm not saying there should be a capital punishment for stupidity, but why don't we just take the safety labels off of everything and let the problem solve itself?
Image

Top
 Profile  
 
 
Posted: Sun Dec 24, 2006 8:40 pm 
Stock as a Rock
Offline
User avatar

Posts: 190

Joined: 30th May 2006

Location: Third Rock From The Sun
Oustide Australia

I did an oil change this morning using a new filter and the warning light is stilll on, are the senders in the same location on XR6 and 3.9 engines the original sender unit from the 3.9 has a small type body where the XR6 has a longer body?

 

_________________

God save Allan Moffat, God bless d**k-Johnson and thank Christ for Marcos Ambrose.........

Top
 Profile  
 
 
Posted: Sun Dec 24, 2006 10:25 pm 
Smokin em up
Offline
User avatar

Age: 43

Posts: 212

Joined: 5th Nov 2006

Gallery: 8 images

Ride: 93 ED

Location: WAGGA WAGGA
NSW, Australia

Mate that could be your problem. Sounds like you have the gauge type fitted to the engine when you only have a light on the dash. Yes the senders are different usually the light ones are smaller than the gauge type and I am pretty sure you can swap them over just put some thread saeler on the thread before installing.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: Google [Bot], longlivethefalcon, PhilsMont and 29 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 3:50 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names