Fordmods Logo

ED Futura, running poorly 

 

Page 1 of 1 [ 3 posts ] 

 
 Post subject: ED Futura, running poorly
Posted: Sun Nov 30, 2014 6:18 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 12

Joined: 15th Nov 2014

Ride: Ford Falcon ED Futura

Location: Sunshine coast
QLD, Australia

this is going to be the end of us, need the car by tomorrow for work. it runs but not very well. it takes 5-6 seconds of cranking to fire when it does fire from cold it runs okay with a slight miss but then the idle will just drop to next to nothing running rough and almost stalling but after a second or two. then it goes back to it's normal idle with a miss but then just drops back to nearly stalling and running rough. we took it to the mechanic the other day it has new NGK leads and plugs cleaned the dizzy cap and installed a new coilpack, cleaned out the throttle body and idle control valve, put it on the diagnostic computer and no bad codes came up. compresson test came up fine, replaced the cold start sensor/coolant temp sensor on the side of the thermostat and replaced fuel filter. went over everything we could think of bar the timing i think and the fuel pump and we're certain it's not the intake gasket anyone have any idea what's wrong with this thing? really need help. also if i put the clutch in and turn the wheel like coming out of a driveway on a downhill slope, the car will stall if the idle drops making it alittle dangerious i found out the other day as it stalled in the middle of the street coming out of a fast food place.
Top
 Profile  
 
 
 Post subject: Re: ED Futura, running poorly
Posted: Mon Dec 01, 2014 2:07 pm 
Tyre Shredder
Offline
User avatar

Age: 26

Posts: 303

Joined: 5th Oct 2012

Gallery: 3 images

Ride: 99 au ute

Location: Perth
WA, Australia

Did you end up replacing tfi/dizzy?

 

_________________

Au series 1 ute. T5 manual, 2.5" redback zorst, Xtreme HD clutch

Top
 Profile  
 
 
 Post subject: Re: ED Futura, running poorly
Posted: Tue Dec 02, 2014 3:55 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 12

Joined: 15th Nov 2014

Ride: Ford Falcon ED Futura

Location: Sunshine coast
QLD, Australia

it wasn't the dizzy, it was a blown fuse under the dash and the fuel rail/injectors were full of dirt. enough crap came out of the fuel rail to make a small pile in the palm of your hand. cleaned everything out cleaned out the throttle body and idle control valve uped the idle slightly so it didn't stall when it missed and you turned the wheel with the clutch in (put too much load on an already running poorly engine making it stall) and it's back to running well ish again. still a slight miss but it's not noticeable unless idling now no affect to acceleration or how the car runs bar a slight hic up as it sits at lights or parked.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 3 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 6:03 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names