Fordmods Logo

Fordmods Advertising

ED valve problem 


Page 1 of 1 [ 2 posts ] 

 Post subject: ED valve problem
Posted: Thu Dec 20, 2007 9:52 pm 
Fordmods Newbie

Posts: 9

Joined: 30th Sep 2007

Location: cragieburn
VIC, Australia

hi guys (and girls) i have an ed xr6

the other day the car started makeing a very loud ticking nosie (sounded like a disel)

my merchnic said it was valves.

is there a way to ajust them??

if so how??

thanks for your time
Posted: Thu Dec 20, 2007 10:06 pm 
Fordmods Junkie
User avatar

Posts: 11607

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Take the rocker cover off and see if the rocker arms aren't snapped or anything that could cause the loud ticking noise. If you haven't touched the engine before I doubt it would be the valve making that noise.

phong =P~



phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: MSNbot Media, peterel and 16 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Wed Oct 26, 2016 5:02 am All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names