Fordmods Logo

ED XR6 Falcon random misfire? 

 

Page 1 of 1 [ 1 post ] 

 
 Post subject: ED XR6 Falcon random misfire?
Posted: Sat Jan 13, 2018 1:25 am 
Fordmods Newbie
Offline

Age: 22

Posts: 1

Joined: 13th Jan 2018

Ride: ED XR6

Location: Tanunda
SA, Australia

Hey there,

I've had my ED Xr6 for about a year and for the most part I've been very happy with it, however its always had a very intermittent misfire issue, sometimes happening when first starting up and also sometimes while driving. It will be running fine and all of a sudden it will start to run extremely rough and backfire. It will usually keep on running with slight throttle but if I let off or give it too much it will stall. In most cases I just pull over, turn the car off and back on and the issue will fix itself and I can just drive off with no issues. This has only happened a hand full of times since I've owned it but seems to be becoming a more frequent issue.

To me it seems like a possible spark issue but I'm finding it hard to diagnose since it happens so infrequently and will usually fix itself soon after it happens. Just wondering if anyone has ever had a similar issue?

Any help would be much appreciated!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Tue Oct 16, 2018 9:14 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names