Fordmods Logo

EF 6 cyl 4.0 rebuild problems 

 

Page 1 of 2 [ 17 posts ] Go to page 1, 2  Next

 
 Post subject: EF 6 cyl 4.0 rebuild problems
Posted: Fri Aug 16, 2013 12:55 pm 
Fordmods Newbie
Offline

Age: 57

Posts: 16

Joined: 31st Jul 2013

Ride: EF Falcon

Location: Melbourne
VIC, Australia

Hi all

I have just rebuilt my 4.0l motor but I am now finding that the motor will not rev consistantly, it idels ok but as soon as i rev it up it starts to back fire and sputter.
I have replaced the ECU with a new one and have also checked the cam timing, all ok.
so I am at a loss as to why it's doing this.
is it necessary to adjust anything else after a rebuild?

Joe
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Fri Aug 16, 2013 1:24 pm 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hi,

Have you checked the base timing ?

I was thinking EL with the timing, but the EF still may have some timing issues. If the ECU was good before you started, it should still be OK.

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Fri Aug 16, 2013 10:25 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Did you use new injectors?
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Sat Aug 17, 2013 9:14 pm 
Fordmods Newbie
Offline

Age: 57

Posts: 16

Joined: 31st Jul 2013

Ride: EF Falcon

Location: Melbourne
VIC, Australia

no still same old injectors and manifold
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Sat Aug 17, 2013 9:19 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Check your injectors, could need cleaning
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Sun Aug 18, 2013 9:52 pm 
Fordmods Newbie
Offline

Age: 57

Posts: 16

Joined: 31st Jul 2013

Ride: EF Falcon

Location: Melbourne
VIC, Australia

where do you take them to be cleaned? and how much would that cost?
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Thu Aug 22, 2013 1:23 pm 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

jjfalcon wrote:
where do you take them to be cleaned? and how much would that cost?


If you already have them out, just take them along to Repco and get exchange ones....works out much the same as getting them cleaned.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Thu Aug 22, 2013 5:10 pm 
Fordmods Newbie
Offline

Age: 57

Posts: 16

Joined: 31st Jul 2013

Ride: EF Falcon

Location: Melbourne
VIC, Australia

no all of the injectors are still attached to the manifold..
new event!!! it now doesn't start at all!!! there is no spark coming out of the spark plaug leads..

can this mean it maybe the coils that have been causing this problem???
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Fri Aug 23, 2013 11:37 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

jjfalcon wrote:
no all of the injectors are still attached to the manifold..
new event!!! it now doesn't start at all!!! there is no spark coming out of the spark plaug leads..

can this mean it maybe the coils that have been causing this problem???


Doesn't necessarily mean the coil pack is stuffed....could be the ECU, Synchronizer, Crank Angle sensor.....etc.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Fri Aug 23, 2013 6:12 pm 
Fordmods Newbie
Offline

Age: 57

Posts: 16

Joined: 31st Jul 2013

Ride: EF Falcon

Location: Melbourne
VIC, Australia

Would a diagnostic unit pick any of this up? if so where can i get one?
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Sun Aug 25, 2013 11:25 am 
Getting Side Ways
Offline
User avatar

Age: 49

Posts: 6467

Joined: 18th Dec 2006

Ride: 93 ED sedan

Power: 161 rwkw

Location: Rockhampton
QLD, Australia

jjfalcon wrote:
Would a diagnostic unit pick any of this up? if so where can i get one?


Maybe....only when something is out of range for the unit.....but if it is something like the injectors are completely clogged ( doubt it, but for diagnostics view), it wouldn't show a code.....same as if the s/plugs won't work, or the HT leads are stuffed...no code will show......same as a dodgy connector won't show either.

 

_________________

http://youtu.be/jJTh9F3Vgg0

Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Fri Aug 30, 2013 9:33 pm 
Getting Side Ways
Offline

Posts: 973

Joined: 15th Nov 2004

Ride: el wagon

Location: melbourne
VIC, Australia

Quote:
back fire and sputter


usually caused by faulty ignition
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Fri Aug 30, 2013 10:21 pm 
Fordmods Newbie
Offline

Age: 57

Posts: 16

Joined: 31st Jul 2013

Ride: EF Falcon

Location: Melbourne
VIC, Australia

I have now replaced the coil, leads and plugs, ensured that the crank angle sensor is in the correct postion and still having the same problem. it idels perfectly but when i put it into drive or reverse (auto) it starts to spatter and backfire with very little power produced as it wouldn't even go up a slightly slopped drive way.

I am at a loss!!! but concerned to take it to ford as this may cost me an arm and a leg for them to check it out.
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Sat Aug 31, 2013 3:44 pm 
Getting Side Ways
Offline

Posts: 973

Joined: 15th Nov 2004

Ride: el wagon

Location: melbourne
VIC, Australia

try the fuel pressure regulator. It is a shiny cylinder type thing at the firewall end of the fuel rail. Try a known good one in its place, as new ones cost an arm and a leg!!

It sounds like a bit of a fuel supply problem.

I remember back in the days when cars had things called "carburetors", a bit of dirt in the jets would cause similar symptoms.
Top
 Profile  
 
 
 Post subject: Re: EF 6 cyl 4.0 rebuild problems
Posted: Tue Sep 17, 2013 4:00 pm 
Fordmods Newbie
Offline

Age: 57

Posts: 16

Joined: 31st Jul 2013

Ride: EF Falcon

Location: Melbourne
VIC, Australia

Problem has now been solved it was a fuel blockage to a couple of injectors.
took out all injectors and had them cleaned, installed them then problem gone!!!

Thanks to all


JJ
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 17 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Sat Dec 16, 2017 5:11 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names