Fordmods Logo

EF cranking but not starting, smoke possibly from BCM.. 


Page 1 of 1 [ 1 post ] 

 Post subject: EF cranking but not starting, smoke possibly from BCM..
Posted: Sat Jan 30, 2010 4:04 pm 
Getting Side Ways

Age: 26

Posts: 971

Joined: 18th Dec 2008

Ride: BA Futura

Location: Hobart
TAS, Australia

Hey guys, I'd really appreciate some help with this one..

Car started fine at home, but the stereo wasn't outputting sound, the actual unit was on though (dunno if it has any relevance, it's not the stock one)
Just as I pulled up at the petrol station I noticed some smoke near the instrument cluster, smelled like barbecued electronics.. The car still ran fine.

After filling up the engine cranks but doesn't start. Everything work (including the instrument cluster) except the door locks and windows. Which leads me to think it's a BCM problem..

Also the coolant temperature light is lit on the dash, but it isn't warm..

The smartlock light isn't flashing or coming on at all, it used to.

Basically have these questions:

Can a screwed BCM cause starting problems?
What would likely cause it to fail if it is the BCM?

Any help would be appreciated, currently it's sitting at a petrol station carpark with both front windows nearly fully down and unlocked..



DCII LTD V8 - leather - low k's
1978 XC '1/2' 500 project 302C
BA Futura wagon
P38 Range Rover HSE

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 24 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Mon Oct 24, 2016 6:05 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names