Fordmods Logo

EF falcon LACK complete power intill 4000rpm 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EF falcon LACK complete power intill 4000rpm
Posted: Wed Aug 08, 2007 12:15 am 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 721

Joined: 31st Dec 2005

Ride: EF V8 Futura, 180sx

Location: Brisbane, Burpengary
QLD, Australia

hey guys
i just installed t5 manual into my car and you feel it s**t load better but engine just not there.
i should let you guys know the engine is a AU engine with modded sub frame to fit.
when i went out for a drive i noticed it had rough idel and lacks complete power intill about 4000rpm area then it takes off like a bloody rocket.

when i converted to manual i noticed that fuel lines were wet. i gave the fuel reg a look and found fuel reg to rail o-ring leaking so i put crap load of vasaline and it seemed to seal it but still didn't fix the problem.

i taking injectors to work tomorrow and ganna get them reco and get few extra o-rings and use them for the fuel reg to rail seal.
i got a few fuel filter and air filter what are about only 7000km old

i thinking it could be map sensor or oxygen sensor

ive replaced intake manifold gasket about 2 weeks ago in attempt to fix the idel issue.

what do you guys think????

cheers,
jason

 

_________________

Ford EF Futura Black
18" koya Strykers, AU engine with port and polish EB head, crow valve springs, standard cam, Large aftermarket RX7 turbo, T5 manual 3" intercooler piping, 600x300x100 intercooler core, MSII with innovate wideband O2 sensor and guage. BA F6 bodykit

Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 12:49 am 
Fordmods Junkie
Offline
User avatar

Posts: 3083

Joined: 22nd Sep 2005

Gallery: 13 images

Ride: EF

Location: Melbourne
VIC, Australia

idd bet a $ on the bbm not switching properly, i had this issue when i bought my car, fixed very quickly after getting the car (got the price down for it too :) )

my issue was some of the vacume lines were put on backwards

 

_________________

Image
latest mod: A Service
MY BUILD THREAD

Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 1:25 am 
Getting Side Ways
Offline
User avatar

Age: 39

Posts: 1807

Joined: 6th Feb 2006

Location: CENTRAL
VIC, Australia

yep like he said ^^^^^ but i am thinking the rough idle could be because of a vacuum leak, you might kill two birds with one stone there.
Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 7:51 am 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 721

Joined: 31st Dec 2005

Ride: EF V8 Futura, 180sx

Location: Brisbane, Burpengary
QLD, Australia

what would happen if i was to remove it from the car and plug up the end? would it runs better? or that my problem? running with to mich flow at lower rpm?

i ganna replace a few vacuum lines and go from there

 

_________________

Ford EF Futura Black
18" koya Strykers, AU engine with port and polish EB head, crow valve springs, standard cam, Large aftermarket RX7 turbo, T5 manual 3" intercooler piping, 600x300x100 intercooler core, MSII with innovate wideband O2 sensor and guage. BA F6 bodykit

Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 10:36 am 
Getting Side Ways
Offline

Posts: 476

Joined: 28th Jan 2005

Ride: 1990 EA Spac

Location: grenfell
NSW, Australia

BBM runs with the manifold changeover held by vacuum until 3800rpm when the vac is released and the BBM switchs to short runners. As said before look for a leak or hose off. When you start the engine you should see the bbm change over as the vacuum comes up. If not then there's the problem. Power will be down if running on short runners until 3800.
There is a switch valve under the passengers side at the rear of the engine bay behind the windscreen washer bottle.

 

_________________

Drive safe, arrive alive

EA Spak EL dash and interior, thermo's,BBM, EF head and cam, superlows,

Top
 Profile  
 
 
Posted: Wed Aug 08, 2007 9:06 pm 
Getting Side Ways
Offline
User avatar

Age: 29

Posts: 721

Joined: 31st Dec 2005

Ride: EF V8 Futura, 180sx

Location: Brisbane, Burpengary
QLD, Australia

i got the injectors reco today and the car idels like a dream the smoothest idel ive herd from any E series falcon so coff or f@rt just perfect pure minus the crap exhaust that will get replaced within the next week.

but problem still there as expected just got one problem covered while i had car off the road.

im going to replace my bbm this weekend with a new one i got which i have been meaning to do the last month ive polished up this manifold so it will look great and it might fix the bbm running problem.

while the the intake manifold off ill check all the vacuum lines for cracks or leaks.
i got plenty of vacuum line sitting in my boot if it required.

what gets me is it was running great other week and i was about half throttle going up hill and it just lost power and had to drive home.

just bit hard to see a vacuum line fail like that. could this problem hae anything to with valve springs?

i think the guy said who im bought the car off said it had duel valve springs installed. I THINK he said that
could be the inner spring failed

 

_________________

Ford EF Futura Black
18" koya Strykers, AU engine with port and polish EB head, crow valve springs, standard cam, Large aftermarket RX7 turbo, T5 manual 3" intercooler piping, 600x300x100 intercooler core, MSII with innovate wideband O2 sensor and guage. BA F6 bodykit

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 13 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 12, 2017 4:31 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names