Fordmods Logo

EF falcon losing oil pressure when hot, please help 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 1:35 pm 
Oompa Loompa
Offline

Age: 21

Posts: 25

Joined: 24th Jan 2015

Ride: 1994 Falcon futura Wagon

Location: Elizabeth East
SA, Australia

hi all I have run into a problem with my EF when I brought it the oil looked a bit old and so decided to give it a change with a new filter and Gulf Western 20-50 SJ CF coded oil and now after about an hours worth of driving my oil light comes on but the motor doesn't sound like its being starved of oil it usually hangs around the MAL range on the temp gauge and the light flickers when this problem happens at idle and sometimes stays on, which is a bit worrying any assistance is appreciated :cry:
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 5:36 pm 
Technical Contributor
Offline
User avatar

Age: 28

Posts: 3705

Joined: 27th Sep 2006

Gallery: 20 images

Ride: ED Falcon

Power: 133 rwkw

Location: Leeton
NSW, Australia

I thought EF/EL were a 15/40 oil recommended...

None the less this was common issue with these models... AFAIK Ford issued a fix to technicians for this and it was to add a resistor inline with the sensor to lift the needle on the gauge... If you screw a master gauge (mechanical) straight into the sender hole you'd find you probably have good oil pressure and it's the factory gauge that is lying... If you have a spare pressure gauge handy it'd be worth a try... My ED did this to me only a couple of times in it's life...

Cheers,
Tim

 

_________________

93 Red ED 5spd Manual Build Thread

Performance: Complete AUII VCT Wiring & Power Train, Pacey Headers, 2.5" Exhaust, Exedy Clutch, DBA Rotors
Visuals: FG XR Wheel, XR Front, 17's, BA 5 Spd Shifter, BA Ghia Window Switches, NL Cluster
Tunes: 8" Pioneer Sub, JBL Speakers, Clarion Double DIN Headunit

Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 6:07 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

young falcon wrote:
hi all I have run into a problem with my EF when I brought it the oil looked a bit old and so decided to give it a change with a new filter and Gulf Western 20-50 SJ CF coded oil and now after about an hours worth of driving my oil light comes on but the motor doesn't sound like its being starved of oil it usually hangs around the MAL range on the temp gauge and the light flickers when this problem happens at idle and sometimes stays on, which is a bit worrying any assistance is appreciated :cry:


Please Clarify a couple of things,

1) What dash is it? Low series (GLi/Futura) or High (XR/Fairmont).

2) You talk of low oil pressure but refer to the temp gauge. Are you say the car is running normal temp when the oil pressure drops.

3) The oil light doesn't come on when the car/oil is cold? or only when Hot?
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 7:37 pm 
Oompa Loompa
Offline

Age: 21

Posts: 25

Joined: 24th Jan 2015

Ride: 1994 Falcon futura Wagon

Location: Elizabeth East
SA, Australia

SWC wrote:
young falcon wrote:
hi all I have run into a problem with my EF when I brought it the oil looked a bit old and so decided to give it a change with a new filter and Gulf Western 20-50 SJ CF coded oil and now after about an hours worth of driving my oil light comes on but the motor doesn't sound like its being starved of oil it usually hangs around the MAL range on the temp gauge and the light flickers when this problem happens at idle and sometimes stays on, which is a bit worrying any assistance is appreciated :cry:


Please Clarify a couple of things,

1) What dash is it? Low series (GLi/Futura) or High (XR/Fairmont).

2) You talk of low oil pressure but refer to the temp gauge. Are you say the car is running normal temp when the oil pressure drops.

3) The oil light doesn't come on when the car/oil is cold? or only when Hot?


Apologies for not making much sense but it is the low series dash, it is normal operating temperature when the problem happens and only happens when hot, like if I travel around an hour or so then it starts flickering and after about another 5-10 minutes it wil
Will be bright
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 9:21 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

So, when it hits "Low" Oil Pressure, the light flickers and then stays on?

Does this occur at revs or only at idle?

If you turn the car off and then restart it straight away, does the light still come on and stay on or does it "reset"?
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 9:55 pm 
Oompa Loompa
Offline

Age: 21

Posts: 25

Joined: 24th Jan 2015

Ride: 1994 Falcon futura Wagon

Location: Elizabeth East
SA, Australia

SWC wrote:
So, when it hits "Low" Oil Pressure, the light flickers and then stays on?

Does this occur at revs or only at idle?

If you turn the car off and then restart it straight away, does the light still come on and stay on or does it "reset"?


Yes it does flicker then stays on, it occurs at idle and the revved, it comes up straight away most times but does occasionally does reset itself
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 10:03 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Either you have a stuffed oil pressure switch (Hope) which is a easy fix or you have bigger problems.

Supercheap do the switches, Triton $11.99 or VDO $14.99. It would pay to put a mechanical gauge on the engine to check the oil pressure.

The oil shouldn't cause an issue. What oil filter did you use?

On the bigger issue side, Oil pump could be on the way out, relief valve sticking open or vanes worn or possibly bottom end is on the way out. How many Km on the engine?
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 10:09 pm 
Oompa Loompa
Offline

Age: 21

Posts: 25

Joined: 24th Jan 2015

Ride: 1994 Falcon futura Wagon

Location: Elizabeth East
SA, Australia

SWC wrote:
Either but have a stuffed oil pressure switch (Hope) which is a easy fix or you have bigger problems.

Supercheap do the switches, Triton $11.99 or VDO $14.99. It would pay to put a mechanical gauge on the engine to check the oil pressure.

The oil shouldn't cause an issue. What oil filter did you use?

On the bigger issue side, Oil pump could be on the way out, relief valve sticking open or vanes worn or possibly bottom end is on the way out. How many Km on the engine?


As far as I know it has done 382,500 thereabouts but I think it was a bandaid job by previous owner, it's got a number corresponding to a EL sedan but has all the EDIS gear, I am using ryco filters
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 10:32 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Filter is good.

Check the switch and see how you go. I hope that is the fix for you.
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Thu Sep 03, 2015 10:34 pm 
Oompa Loompa
Offline

Age: 21

Posts: 25

Joined: 24th Jan 2015

Ride: 1994 Falcon futura Wagon

Location: Elizabeth East
SA, Australia

SWC wrote:
Filter is good.

Check the switch and see how you go. I hope that is the fix for you.


Sure, I will let everyone know how it goes
Top
 Profile  
 
 
 Post subject: Re: EF falcon losing oil pressure when hot, please help
Posted: Fri Sep 04, 2015 8:42 am 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

Check to see if there is any oil leaking around the Oil Switch.

On the Oil Gauge Sensor units, they can start leaking and start giving false readings.

I would still put a proper pressure gauge on it and have it checked.
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: No registered users and 25 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Dec 19, 2017 9:04 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names