Fordmods Logo

EF II ghia, terrible fuel consumption/weird idle/sluggish 


Page 1 of 1 [ 1 post ] 

 Post subject: EF II ghia, terrible fuel consumption/weird idle/sluggish
Posted: Tue Mar 16, 2010 3:29 am 
Getting Side Ways

Posts: 590

Joined: 4th May 2007

Ride: 1992 EBII Fairmont

Location: Aga
VIC, Australia

Hey guys

I've been trying to fix an issue with my EF II ghia (coil pack) regarding an odd idle, terrible consumption and a lack of power.

First of all this is what's been replaced: Plugs, leads, oxy sensor, inlet manifold gasket, fuel/air filters, oil, coolant, clean ISC/TB

I'll start with the idle. Is fine in Park/Neutral but when you put it in drive/in gear the car vibrates (not rough or lumpy) like a bloody massage chair
If I rev the car in neutral to say 2000 RPM and then take my foot of the pedal, the revs should normally drop to idle speed. But with my car the revs drop to something like 300RPM and the car runs rough as hell and struggles for a second, then it goes back up and returns to it's normal idle. Normal idle is really smooth but every few seconds it runs rough for like a millisecond, it's extremely quick and hard to notice.

Fuel consumption: I'm getting 340-380k's from filling up 62 liters (that's below the red on the gauge/basically a dry tank) which is like 15/17 liters per 100k's. Map sensor hose is on, it blows no smoke. This is killing the wallet.

Lack of power: It's sluggish most days but on rare occasions it's completely responsive and drives like it should, it has a mind of it's own, it drives smooth whether it has power one day or no power the next. I have no idea how to explain this one.
When it's sluggish I need to rev it higher to achieve a slower result than I would revving it lower on a good day.

Also another annoying thing is I can hear a few vacuum hoses behind the dash making rather loud noises, not like a leak. Sounds sort've like Darth Vadar I guess haha.

Any suggestions? Think these problems are all connected somehow?

Display posts from previous:
Sort by  
 Page 1 of 1  [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 30 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Fri Oct 21, 2016 8:37 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names