Fordmods Logo

EL died again... 

 

Page 1 of 1 [ 11 posts ] 

 
 Post subject: EL died again...
Posted: Tue May 06, 2008 1:19 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

this morning on the way to tafe, i was slowing down to turn right at the traffic lights, revs go down as usual when slowing, then i stopped and the revs kept going down and the motor stopped :?

tried to start it but it just cranks over, dosent fire. did a spark test on no.2 lead after no.1 fell apart in my hand :) and its got plenty of spark. all fuses and relays are OK.

now theres no power to the fuel pump :? also, the oil pressure and battery light dont show up on the cluster, and also the clock and radio reset, and the radios frozen.

so f**k if i know whats wrong! anyone know of anything that could have caused this?

im guessing ECU playing up?

if anyone couild help itd be greatly appreciated.

cheers fellas :)

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Tue May 06, 2008 1:30 pm 
Stock as a Rock
Offline

Posts: 125

Joined: 2nd Dec 2007

Location: bellbrook
NSW, Australia

ignition???
my xf did a similar thing..wound spark the works but wouldnt fire,no reds..turned out my kill switch was f**k my ignition..
Top
 Profile  
 
 
Posted: Tue May 06, 2008 2:03 pm 
Getting Side Ways
Offline

Age: 28

Posts: 1135

Joined: 27th Oct 2005

Gallery: 3 images

Location: SA
SA, Australia

Check the fuses, i Beleive there is one that is like CRT LMP or something. Cant remember it. Basicly just check all your fuses, as that one when blown exibits all of those poblems.
Top
 Profile  
 
 
Posted: Tue May 06, 2008 9:44 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

fairmont599 wrote:
Check the fuses, i Beleive there is one that is like CRT LMP or something. Cant remember it. Basicly just check all your fuses, as that one when blown exibits all of those poblems.


yeah every fuse was fine. turns out the fuel pump shat itself. this is the second time this car has broken down in the 6 weeks ive owned it. im f**k p****d off with the wanker car dealer who wont do a f**k thing about it. :evil:

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Tue May 06, 2008 11:49 pm 
Getting Side Ways
Offline

Age: 28

Posts: 1135

Joined: 27th Oct 2005

Gallery: 3 images

Location: SA
SA, Australia

Man that sucks! Hope she doesnt give ya too much trouble.
Top
 Profile  
 
 
Posted: Tue May 06, 2008 11:50 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

lol yeah hopefully this is the last thing to go wrong with it. being at tafe dosent help either with no income, good thing my olds are helping me out for the time being.

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
 Post subject: fuel
Posted: Wed May 07, 2008 2:13 am 
Getting Side Ways
Offline

Posts: 652

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Mate what a pain. You may have had bad fuel. Make sure you change filter and try not to run it low on fuel as that can gunk it up and cause it to fail early. At least you have a Falcon and parts are easy and cheap to come by. :D
Top
 Profile  
 
 
Posted: Wed May 07, 2008 2:46 pm 
Getting Side Ways
Offline
User avatar

Age: 32

Posts: 5540

Joined: 31st Oct 2005

Gallery: 28 images

Ride: NC II Fairlane

Location: morayfield
QLD, Australia

i know my fuel tank is clean... mine got completely drained of fuel while it had no rego... couldnt work out why it wouldnt run, guage said 1/4 tank, trip computer said 80k's. turns out the fuel sender unit jammed itself after being there unmoved for soo long, the tank was bone dry... ended up frying the fuel pump 2 weeks later tho lol.

ghia97 he will have a new filter with the new pump ;)

 

_________________

Member #7418
KB Laser White lightning Turbo - B6T
Turbo NC II Fairlane Ghia
http://www.fordmods.com/the-garage-f53/my-new-nc-ii-fairlane-dial-up-warning-t50380.html

Top
 Profile  
 
 
Posted: Wed May 07, 2008 10:40 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

huggiebear wrote:
i know my fuel tank is clean... mine got completely drained of fuel while it had no rego... couldnt work out why it wouldnt run, guage said 1/4 tank, trip computer said 80k's. turns out the fuel sender unit jammed itself after being there unmoved for soo long, the tank was bone dry... ended up frying the fuel pump 2 weeks later tho lol.

ghia97 he will have a new filter with the new pump ;)


i had a new filter put on about 1200km ago anyway. the stuff that came out of it was BLACK :shock:

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
 
Posted: Wed May 07, 2008 10:56 pm 
Getting Side Ways
Offline

Age: 66

Posts: 2548

Joined: 18th Mar 2006

Ride: EF-XR8chaser

Location: wollongong
NSW, Australia

alfy wrote:
huggiebear wrote:
i know my fuel tank is clean... mine got completely drained of fuel while it had no rego... couldnt work out why it wouldnt run, guage said 1/4 tank, trip computer said 80k's. turns out the fuel sender unit jammed itself after being there unmoved for soo long, the tank was bone dry... ended up frying the fuel pump 2 weeks later tho lol.

ghia97 he will have a new filter with the new pump ;)


i had a new filter put on about 1200km ago anyway. the stuff that came out of it was BLACK :shock:
country petrol? or rust

 

_________________

R.I.P HANS HARTMAN

Top
 Profile  
 
 
Posted: Wed May 07, 2008 11:02 pm 
Getting Side Ways
Offline
User avatar

Age: 28

Posts: 5889

Joined: 2nd Mar 2006

Gallery: 5 images

Ride: '14 Grand Cherokee

Location: Port Lincoln
SA, Australia

im guessing country petrol. it came from Kimba, SA, and it sat in a shed for 3 years only being started rarely, so im guessing that contributed to it.

 

_________________

11/93 ED OPT20 GLi | Full Boat Spec

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 11 posts ] 

Who is online

Users browsing this forum: Facebook [Bot], Google [Bot] and 34 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 10:40 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names