Fordmods Logo

El fairmont I6 issues, any ideas? 

 

Page 1 of 2 [ 25 posts ] Go to page 1, 2  Next

 
 Post subject: El fairmont I6 issues, any ideas?
Posted: Sun Jul 27, 2014 7:15 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 11

Joined: 2nd Jul 2012

Ride: Ef Falcon

Location: Chiltern
VIC, Australia

Alright, hey guys/girls!

So basically I've bought myself another e series falcon, just really like them for some reason!
Now my issues are, fluctuating idle between 400-800rpm sometimes it feels as though it's going to stall out as it will cough and splutter, but other times it just shakes the car.
Once the car is driving the idle issue isn't felt whatsoever, I've replaced fuel filter, air filter, serviced it, cleaned throttle body... Apparently the plugs and leads on it are new, so I've left those alone for now

Another thing I noticed that may be contributing to it, is that A)there's regurarly condensation coming from the exhaust and B) the temp gauge never even gets near the L on NORMAL, so I'm assuming that's far too cold?

Any ideas?
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Sun Jul 27, 2014 7:41 pm 
Moderator
Offline
User avatar

Age: 40

Posts: 2327

Joined: 6th Oct 2005

Ride: 93EB Fairmont / BA Falcon XR6T

Location: Western Sydney
NSW, Australia

Have you tried cleaning the ISC ?

 

_________________

93 EB II Fairmon8 with 17' EL GT's / Clear indicators / H.I.Ds / Sports exhaust / Lowered 2' / K&N / XR6 ECU.
2004 BA MKI XR6T in Lightning Strike paint / K&N / XR8 bonnet / BF lights and a few tweaks.

Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Sun Jul 27, 2014 8:00 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 11

Joined: 2nd Jul 2012

Ride: Ef Falcon

Location: Chiltern
VIC, Australia

How do I do that? /:
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Mon Jul 28, 2014 12:37 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

A couple of thoughts:
1) Try resetting the ECU: With the ignition switche off, unplug the ECU for a minute or so, or unplug the battery for half an hour (don't know why it needs to be this long).
2) I would throw some decent injector cleaner into the tank. Should be done a couple times a year anyway.
3) If that doesn't work, it may be time to replace your oxygen sensor.
4) If your engine temp is too low, you may have a thermostat stuck open. I would replace it. Low engine temp will cause the ECU to add fuel, which may affect the idle.
5) If you are getting "condensation" from your exhaust even after the engine and exhaust are at full operating temp, it is possibly a head gasket issue - coolant leaking into a cylinder. But you would know, as you would be topping up your coolant a couple times a week.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Tue Jul 29, 2014 7:27 am 
Fordmods Newbie
Offline

Age: 23

Posts: 11

Joined: 2nd Jul 2012

Ride: Ef Falcon

Location: Chiltern
VIC, Australia

I'll try the ecu trick!
Yeah my old man is a mechanic but I don't see him often but he looked over it last night and said my thermostat was stuck open, so first things first, I'll replace that, injector cleaner has been added, and it's definitely not a head issues, my old man thinks it's dumping unburnt fuel due to running to rich ?
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Tue Jul 29, 2014 7:43 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

When was your O2 sensor last replaced?

Also check your MAP sensor.
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Tue Jul 29, 2014 7:52 pm 
Getting Side Ways
Offline
User avatar

Age: 51

Posts: 433

Joined: 18th Jul 2009

Ride: NL FAIRLANE BA TURBO POWERED

Location: ballarat
VIC, Australia

Also check for vacuum leaks around inlet manifold.
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Wed Jul 30, 2014 7:19 am 
Fordmods Newbie
Offline

Age: 23

Posts: 11

Joined: 2nd Jul 2012

Ride: Ef Falcon

Location: Chiltern
VIC, Australia

Not sure about the O2 sensor, I probably should replace is regardless
Checked map sensor and for vacuum leaks, everything seems okay
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Wed Jul 30, 2014 8:40 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

If your thermostat is stuck open, it will be running very rich, which can cause idle surging like you are experiencing. The ECU sees the low temp and stays in cold start mode, dumping extra fuel in. Just like running a carby engine with the choke held closed (if you're old enough to remember when carbs were devices for supplying fuel ;-) ).

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Sun Aug 10, 2014 8:27 pm 
Fordmods Newbie
Offline

Age: 23

Posts: 11

Joined: 2nd Jul 2012

Ride: Ef Falcon

Location: Chiltern
VIC, Australia

Alright, so the idle has gotten worse and the motor is lacking power severely, it won't even break traction in the dirt, and struggles to rev past 3,500rpm without surging

I've replaced, coil, leads, plugs, fuel/air/oil filter, I've checked, the fuel pressure reg, checked for vac leaks, etc

Any ideas? Cause I'm running out of money pretty quick and I need the car running properly /:
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Sun Aug 10, 2014 9:07 pm 
Fordmods Newbie
Offline

Age: 32

Posts: 8

Joined: 22nd Nov 2005

Location: Canning Vale
WA, Australia

Im having exact same problems, ive done the same thing as you just keep replacing bits and still hasnt come good. I just changed the head gasket and mine is still doing it so not related to that im thinking its a dead sensor somewhere.
Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Sun Aug 10, 2014 10:14 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Do you know anyone with a similar car? You could try temporarily swapping in their ECU to eliminate that as a possible source of the problem.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Mon Aug 11, 2014 8:15 am 
Getting Side Ways
Offline
User avatar

Age: 23

Posts: 461

Joined: 31st Mar 2013

Ride: 96 EL XR6

Location: Hervey Bay
QLD, Australia

I've heard that these ecu's are quite common to drop some solinoids or something for the ISC? Which causes them to play up? Someone correct me if I'm wrong,

I'd swap in another ECU and try that,

 

_________________

EL XR6, T5 Speed - Full Factory Fitted Tickford Body Kit, AU Engine, Billet Camtech 845 Cam, J3 Chip, MLS Gasket, Intake, Extractors, High flow cat, 2 1/2in exhaust, K&N Air Filter, 3.45 LSD, - My Pride and Joy

Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Mon Aug 11, 2014 10:22 pm 
Getting Side Ways
Offline

Posts: 836

Joined: 1st Apr 2005

Gallery: 4 images

Ride: EF XR6 Wagon, AU2 XR6 VCT

Power: 148 rwkw

Location: Auckland
New Zealand

Just an idea I came across on another site: could the catalytic converter be blocked? That would definitely cause your revs to just hit a wall and would reduce power severely.

 

_________________

95 EF XR6 wagon, 17" FTRs, DBA, QFM, KYB/Koni, AU block, ported EF head, SS Inductions, Territory intake, MLS gasket, milled, Franklin RH24B cam, Coby headers, no cat, Tickford 2.5", 2800rpm stall, J3 chip

Top
 Profile  
 
 
 Post subject: Re: El fairmont I6 issues, any ideas?
Posted: Tue Aug 12, 2014 10:24 am 
Fordmods Newbie
Offline

Age: 23

Posts: 11

Joined: 2nd Jul 2012

Ride: Ef Falcon

Location: Chiltern
VIC, Australia

From all inspections cat is fine, one thing I noticed was corrosion in my dizzy, so I'm replacing that this week, if that doesn't work I'll try the ecu! And when I figure out what is causing it I'll post the answer as from what I can tell plenty of people are having the same issue and no one seems to post what they did to fix it!
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 25 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: Google Adsense [Bot] and 16 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 4:48 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names