Fordmods Logo

el fairmont, idle revving higher then usual 

 

Page 1 of 1 [ 14 posts ] 

 
 Post subject: el fairmont, idle revving higher then usual
Posted: Wed Dec 29, 2010 9:40 pm 
Oompa Loompa
Offline

Age: 25

Posts: 21

Joined: 19th Apr 2008

Gallery: 42 images

Location: brisbane
QLD, Australia

iv done a manual conversion on my el fairmont ghia and put a 1673 wade cam in it with the j3 chip. but before i did any of that the idle of the car has a mind of its own, like sometimes it revs under 1000 and sometimes way to high only happens when im stationary, and i dont no what it is. has anyone got any ideas what it could be?


thanks
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Wed Dec 29, 2010 10:42 pm 
Fordmods Junkie
Offline
User avatar

Posts: 11738

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

How long have you driven the car since you put everything in? The computer might still be learning the idle.

Also what tune is on the J3 chip?

I had a random idle when I was running the auto ECU only. Got a J3 with an EL XR6 Manual tune and it took about a week or two before it idled properly.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Wed Dec 29, 2010 10:55 pm 
Oompa Loompa
Offline

Age: 33

Posts: 25

Joined: 12th Dec 2010

Ride: EL Falcon

Location: Perth
WA, Australia

Just something very obvious, but make sure that the throttle cable isn't getting stuck. Disconnect the cruise control from the throttle too.
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Wed Dec 29, 2010 11:33 pm 
NSW Cruise Moderator
Offline
User avatar

Age: 39

Posts: 7331

Joined: 5th Nov 2004

Gallery: 12 images

Ride: TE50

Location: ɹǝpun uʍop
NSW, Australia

unplug your ISC, see if your revs drop to a more desirable level.

 

_________________

Image

I have a car.

Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Wed Dec 29, 2010 11:56 pm 
Getting Side Ways
Offline
User avatar

Age: 33

Posts: 1322

Joined: 21st Dec 2004

Gallery: 40 images

Ride: EF GLi/Ghia bitsa

Location: Melbourne
VIC, Australia

First thing to do is check for vac leaks and clean out the ISC, as mentioned, disconnect the ISC and see if the revs drop.

Gab
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Thu Dec 30, 2010 11:08 am 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

My accelerator pedal gets stuck sometimes.
Only notice it at idle at lights. Rather then sitting at 750-800 it'll sit around 1100.
I just stick my foot under the pedal and lift it up, have you tried this?
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Fri Jan 07, 2011 12:47 pm 
Oompa Loompa
Offline

Age: 25

Posts: 21

Joined: 19th Apr 2008

Gallery: 42 images

Location: brisbane
QLD, Australia

phongus wrote:
How long have you driven the car since you put everything in? The computer might still be learning the idle.

Also what tune is on the J3 chip?

I had a random idle when I was running the auto ECU only. Got a J3 with an EL XR6 Manual tune and it took about a week or two before it idled properly.




i got a custom tune j3 chip to make the auto ecu think its a manual + its tickford+ 1673 cam+ exsahust an etc but iv been driving it around for over 3 weeks now and the idle still has mind of its own but i might try a few things. like take the irs off and see if the idle drops? and disconnect the cruse control. thanks everyone
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Fri Jan 07, 2011 12:49 pm 
Oompa Loompa
Offline

Age: 25

Posts: 21

Joined: 19th Apr 2008

Gallery: 42 images

Location: brisbane
QLD, Australia

MarkIrl wrote:
Just something very obvious, but make sure that the throttle cable isn't getting stuck. Disconnect the cruise control from the throttle too.




i dident even think of disconecting the cruse control that could be it. thanks ill give it ago today
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Fri Jan 07, 2011 12:50 pm 
Oompa Loompa
Offline

Age: 25

Posts: 21

Joined: 19th Apr 2008

Gallery: 42 images

Location: brisbane
QLD, Australia

dc_todd wrote:
unplug your ISC, see if your revs drop to a more desirable level.




i dont no where the isc is but im sure ill be able to look it up and find it when i give it ago today thanks
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Fri Jan 07, 2011 12:52 pm 
Oompa Loompa
Offline

Age: 25

Posts: 21

Joined: 19th Apr 2008

Gallery: 42 images

Location: brisbane
QLD, Australia

Gab1 wrote:
First thing to do is check for vac leaks and clean out the ISC, as mentioned, disconnect the ISC and see if the revs drop.

Gab



yeah one of my mates said it could be the a vacum hose leak, iv just been to busy to have a look. hopefully this rain go's away on the coast and ill b able to do it this week end.
thanks
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Fri Jan 07, 2011 2:11 pm 
Oompa Loompa
Offline

Age: 25

Posts: 21

Joined: 19th Apr 2008

Gallery: 42 images

Location: brisbane
QLD, Australia

87SIlude wrote:
My accelerator pedal gets stuck sometimes.
Only notice it at idle at lights. Rather then sitting at 750-800 it'll sit around 1100.
I just stick my foot under the pedal and lift it up, have you tried this?



no i havent really thought of that, but im going to give everyones ideas to try fix it, could be that, thanks ill look into it.
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Fri Jan 07, 2011 2:20 pm 
Getting Side Ways
Offline

Age: 26

Posts: 1109

Joined: 4th Sep 2009

Ride: 92 EB s

Location: DORRIGO
NSW, Australia

Best of luck mate.
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Mon Apr 02, 2012 2:42 pm 
Parts Gopher
Offline

Posts: 67

Joined: 28th Aug 2010

Ride: XG Longreach + ED XR6

Location: melbourne
VIC, Australia

87SIlude wrote:
My accelerator pedal gets stuck sometimes.
Only notice it at idle at lights. Rather then sitting at 750-800 it'll sit around 1100.
I just stick my foot under the pedal and lift it up, have you tried this?


Do you still have this problem? I have the same problem on my XG, and thinking it was a stretched cable I swapped it for my ED cable, which seems to have made things worse. Its a nuisance when you need to brake in a hurry (especially on a decline) and the engine wants to hold 1500rpm.
Top
 Profile  
 
 
 Post subject: Re: el fairmont, idle revving higher then usual
Posted: Mon Apr 02, 2012 3:21 pm 
Parts Gopher
Offline

Posts: 85

Joined: 13th Oct 2008

Ride: XG ute

Location: Gold Coast
QLD, Australia

Have you checked that the butterfly in the throttle body is completely closed? If it is try unplugging the idle speed controller to see if it affects the idle, could show if it's electrical or a throttle body/cable problem
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 14 posts ] 

Who is online

Users browsing this forum: No registered users and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
cron

 

 

It is currently Tue Dec 12, 2017 11:24 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names