Fordmods Logo

Fordmods Advertising

El falcon chage head and now no compreshen 

 

Page 1 of 1 [ 12 posts ] 

 
 Post subject: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 11:55 am 
Fordmods Newbie
Offline

Age: 33

Posts: 7

Joined: 23rd Aug 2009

Ride: XF-hybrid,El

Location: Melbourne
VIC, Australia

El falcon change head and now no compression ???
has anyone had this happen before mind you it has the wrong cam in the head???
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 11:56 am 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

you havn't provided enough information for any of to give you any real help.

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 12:04 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 7

Joined: 23rd Aug 2009

Ride: XF-hybrid,El

Location: Melbourne
VIC, Australia

well what info would you like just ask and i will tell.

the head if off a 97 el wagon with a 95AA part number and the cam has a 94DA part number on it.
there for the cam dose not match the head and the head that was on there was a 94DA part number.

so there for where have i gone wrong ??? y dose she have spark and flue pres but no compression someone told me that there may be a bent vale???

any info would be good need more info just ask need the car done asap !!!
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 12:10 pm 
Getting Side Ways
Offline

Posts: 6449

Joined: 11th Nov 2004

If it's got zero compression across all 6 cyls after a head change its holding valves open.

Part number on the came doesn't matter, all the stock cams have the same base circle diameter and interchangeable.

Why did you replace a tickford head, 'DA' is a tickford number, with a regular head? the 94DA cam will be a late EDXR or early EFXR cam.

 

_________________

PERMANENTLY BANNED

Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 12:18 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 7

Joined: 23rd Aug 2009

Ride: XF-hybrid,El

Location: Melbourne
VIC, Australia

sorry gents got the part numbers wrong for the heads the old one is a 94AB and the new one is 95AA
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 12:23 pm 
Fordmods Newbie
Offline

Age: 33

Posts: 7

Joined: 23rd Aug 2009

Ride: XF-hybrid,El

Location: Melbourne
VIC, Australia

tickford_6 wrote:
If it's got zero compression across all 6 cyls after a head change its holding valves open.

Part number on the came doesn't matter, all the stock cams have the same base circle diameter and interchangeable.

Why did you replace a tickford head, 'DA' is a tickford number, with a regular head? the 94DA cam will be a late EDXR or early EFXR cam.


the engine turns over but it is like you are just turning it over without a head on it ???
its holding valves open ??? would you say that the head has bent vales or some thing wrong ????
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 2:42 pm 
Getting Side Ways
Offline
User avatar

Age: 48

Posts: 1634

Joined: 8th Jul 2007

Gallery: 21 images

Ride: EL F100 CAPRI XR EF

Power: 234 rwkw

Location: brighton
SA, Australia

pull a spark plug out and hold your finger aver the plug hole, have a mate crank it over and see if theres any compression.
sometimes they take a bit of cranking to get it to fire and start up, did u do the timing etc by the book when u refitted it
the cam wasnt a regrind was it?
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 4:08 pm 
Moderator
Offline

Posts: 14498

Joined: 7th Nov 2004

Ride: ford falcon

Location: a shit suburb in sydney
NSW, Australia

sounds like the cam timing is out???
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Sun May 16, 2010 4:40 pm 
Fordmods Newbie
Offline

Age: 47

Posts: 14

Joined: 14th May 2010

Ride: Ford BA Mk2

Power: 162 rwkw

Location: Adelaide
SA, Australia

TROYMAN wrote:
sounds like the cam timing is out???



That sounds about right...... :|
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Thu Oct 06, 2016 11:59 pm 
Fordmods Newbie
Offline

Age: 55

Posts: 8

Joined: 6th Apr 2015

Ride: EL GLi 6cyl

Location: Gordon
ACT, Australia

:evil:

Sorry about this thread from the dead, but I have just done a front cover reseal on my EL, and it now has no comp on 1 and 6. The others are 180 cold!

Any ideas? While the timing was difficult and stopping did occur, it wasn't harsh.

Cheers

Kevin
Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Fri Oct 07, 2016 9:22 am 
Getting Side Ways
Offline

Age: 47

Posts: 425

Joined: 3rd Jan 2005

Ride: AU XR6 with BF Turbo engine

Location: Sydney
NSW, Australia

Did you rotate the engine at all with the chain off?

Sounds like the pistons may of hit the valve on 1 & 6 and bent them

 

_________________

RIP :( 1x confused Falcon..EL Falcon with full AU running gear...VCT, 5 speed, IRS, AUII front suspension, brakes, and steering RIP

Top
 Profile  
 
 
 Post subject: Re: El falcon chage head and now no compreshen
Posted: Fri Oct 07, 2016 9:26 am 
Fordmods Junkie
Offline
User avatar

Posts: 11617

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

KevinED wrote:
:evil:

Sorry about this thread from the dead, but I have just done a front cover reseal on my EL, and it now has no comp on 1 and 6. The others are 180 cold!

Any ideas? While the timing was difficult and stopping did occur, it wasn't harsh.

Cheers

Kevin


Sorry I am a bit confused from both posts you made (the other being in the manual conversion thread).

By front cover seal, do you mean timing chain cover? If so, did you remove the timing cover? Did you reset the timing chain tensioner after reinstalling the timing cover?

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 12 posts ] 

Who is online

Users browsing this forum: No registered users and 22 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 07, 2016 7:32 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names