Fordmods Logo

El Falcon lack of power? 

 

Page 1 of 2 [ 19 posts ] Go to page 1, 2  Next

 
 Post subject: El Falcon lack of power?
Posted: Mon Nov 04, 2013 10:11 pm 
Parts Gopher
Offline
User avatar

Age: 25

Posts: 90

Joined: 19th Feb 2013

Ride: NL Fairlane Ghia

Location: Sydney
NSW, Australia

Wondering whether anyone can help me with where to look concerning my car's power. It just doesn't seem to have as much... punch as it should. It has performance modifications and all, but just doesn't seem like it's performing as it should. I drove my friend's completely stock EL Falcon and it felt WAY punchier than mine. Mine seems to have very little power at takeoff, and even when I put my foot down, it doesn't seem as if it's giving all it's got.

Mods: 2.5" Redback catback, 3" stainless steel intake, Spectre POD filter, EL GT snorkel, advanced timing, some minor headwork done by the old owner and an overhauled cooling system.

Anyone have any idea where to look first? It feels like vacuum is escaping somewhere, although I'm not sure on that (I also haven't been able to locate any leaks.)

EDIT: Performance also seems to get worse the longer I drive. It generally goes pretty damn well when it's between cold and fully warmed up.

 

_________________

4.0L Tickford six, 1645b E-series custom grind, MLS gasket, performance valve springs, 3" stainless intake, extractors, 2.5" Lukey, 100cpi hi-flow, T5 manual, J3 tune.

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Mon Nov 04, 2013 10:58 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

where is your pod fitted? Does it have a full heat shield? Post a pic of pod location could just be a case of heat soak. If you say its good on cold mornings and lags when warmer this could be the prob?

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Tue Nov 05, 2013 12:20 am 
Parts Gopher
Offline
User avatar

Age: 25

Posts: 90

Joined: 19th Feb 2013

Ride: NL Fairlane Ghia

Location: Sydney
NSW, Australia

123esproc wrote:
where is your pod fitted? Does it have a full heat shield? Post a pic of pod location could just be a case of heat soak. If you say its good on cold mornings and lags when warmer this could be the prob?


POD's in a box, but it's SLIGHTLY open as I can't close it with the POD inside (issue with the steel pipe length, I think it needs to be cut a little.) Unless a BA box lid will fit, not sure what to do there.

 

_________________

4.0L Tickford six, 1645b E-series custom grind, MLS gasket, performance valve springs, 3" stainless intake, extractors, 2.5" Lukey, 100cpi hi-flow, T5 manual, J3 tune.

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Tue Nov 05, 2013 8:15 am 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

Ba box lid won't fit an au box you will need to replace the whole box unfortunately mate but you may be able to. improvise and create a heatsheild around the box or opening in box to test the heat soak theory? I used a heavy rubber mat as heatsheild and works a treat. As cold air is more.combustable than hot air Cheers

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Tue Nov 05, 2013 11:08 pm 
Stock as a Rock
Offline
User avatar

Age: 25

Posts: 164

Joined: 1st Jan 2010

Ride: EF manual Monty

Location: canberra
ACT, Australia

I would be looking at timing. Bad timing will cause this. i had my el with plenty of mods, timing was advanced too much and it ran well but went like a bag of d**k compared to cars I had with less work. Took it back and reset the timing and went like a rocket once again. =)

 

_________________

R.I.P My red beast :(

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Tue Nov 05, 2013 11:25 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

Performance gets worse as the car warms.up ? Does this really sound like timing? I would've thought timing wouldn't change whether its warm or cold?

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Tue Nov 05, 2013 11:41 pm 
Stock as a Rock
Offline
User avatar

Age: 25

Posts: 164

Joined: 1st Jan 2010

Ride: EF manual Monty

Location: canberra
ACT, Australia

Sorry missed that bit but always something to look at when power is down

 

_________________

R.I.P My red beast :(

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 12:36 am 
Parts Gopher
Offline
User avatar

Age: 25

Posts: 90

Joined: 19th Feb 2013

Ride: NL Fairlane Ghia

Location: Sydney
NSW, Australia

Yeah, timing was only advanced about 5 degrees. Boxed up the POD properly this afternoon, but it still feels like something is holding it back. I can hear a hissing sound from around the cat area. Could it be possibly letting exhaust gasses escape? Any way I can be sure if it's leaking?

 

_________________

4.0L Tickford six, 1645b E-series custom grind, MLS gasket, performance valve springs, 3" stainless intake, extractors, 2.5" Lukey, 100cpi hi-flow, T5 manual, J3 tune.

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 2:00 am 
Getting Side Ways
Offline
User avatar

Age: 102

Posts: 466

Joined: 22nd Jun 2011

Ride: '97 EL Fairmont Ghia

Location: Perth
WA, Australia

Leaky exhaust wont affect power, unless its before the oxygen sensor, which might mess with the AFRs.

Perhaps do a compression test?

Are you sure you've got the timing right? Maybe you turned the dizzy the wrong way? Or maybe too far advanced and the computer is cutting it back for safety?

Just some ideas.

 

_________________

EL Ghia

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 11:15 am 
Parts Gopher
Offline
User avatar

Age: 25

Posts: 90

Joined: 19th Feb 2013

Ride: NL Fairlane Ghia

Location: Sydney
NSW, Australia

I had the timing done by Bruce Heinrich down here in Adelaide, so I know it was done properly. I will try a compression test though, cheers!

 

_________________

4.0L Tickford six, 1645b E-series custom grind, MLS gasket, performance valve springs, 3" stainless intake, extractors, 2.5" Lukey, 100cpi hi-flow, T5 manual, J3 tune.

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 4:55 pm 
Technical Contributor
Offline

Age: 60

Posts: 6817

Joined: 22nd Jun 2005

Gallery: 8 images

Ride: EF Fairmont

Location: Campbelltown
NSW, Australia

xELFalconx wrote:
I can hear a hissing sound from around the cat area. Could it be possibly letting exhaust gasses escape? Any way I can be sure if it's leaking?


Blocked Cat.
Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 6:39 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

+1 cat

 

_________________

Image

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 6:44 pm 
Getting Side Ways
Offline

Age: 34

Posts: 1110

Joined: 27th Dec 2011

Gallery: 6 images

Ride: ef falcon futura

Power: 154 rwkw

Location: Koo Wee Rup
VIC, Australia

+2 cat, was going to say something before but was on my phone and its a prick to type on.

 

_________________

ef futura, pacemakers, 2.5inch catback, k&n panel filter and 3.45 lsd. extractors/cat, ticky head, custom cam grind, t5. now onto cosmetics.

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 7:37 pm 
Parts Gopher
Offline
User avatar

Age: 25

Posts: 90

Joined: 19th Feb 2013

Ride: NL Fairlane Ghia

Location: Sydney
NSW, Australia

"now, I have a real loss of power, occasionally I will get a sulfer smell from the exhaust. She has lost acceleration and she doesnt seem to want to rev or hold the rev very well. She feels bogged down like I am driving into a large wall of air."

Man, this guy put it perfectly. This is exactly what my car feels like. Must be the cat then. Cheers guys. :)

 

_________________

4.0L Tickford six, 1645b E-series custom grind, MLS gasket, performance valve springs, 3" stainless intake, extractors, 2.5" Lukey, 100cpi hi-flow, T5 manual, J3 tune.

Top
 Profile  
 
 
 Post subject: Re: El Falcon lack of power?
Posted: Wed Nov 06, 2013 7:43 pm 
Tyre Shredder
Offline
User avatar

Age: 31

Posts: 384

Joined: 24th Feb 2012

Gallery: 58 images

Ride: 2001 au forte 6cyl

Location: gladstone
SA, Australia

Your suffocating your beast bro :0

 

_________________

Image

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 2  [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 24 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Fri Dec 15, 2017 8:50 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names