Fordmods Logo

Fordmods Advertising

EL Falcon misses under load 


Page 1 of 1 [ 2 posts ] 

 Post subject: EL Falcon misses under load
Posted: Thu Aug 28, 2014 7:40 pm 
Getting Side Ways
User avatar

Age: 36

Posts: 1421

Joined: 5th Nov 2004

Ride: 98 EL Falcon - Last of the EL's

Location: Muswellbrook
NSW, Australia

car runs fine when idling and gently accelerating (& cruising) but if you need to accelerate harder then the car doesn't want to comply and you can hear a definite miss the engine starts to run like crap and there is no power, i changed the oil and there wasn't even a trace of coolant in the oil so it cant be the head gasket *touches wood*

so far i have replaced the spark plugs but due to a supply problem i am getting the leads changed in the next few days, none of the shops had any leads for an EL Falcon lol (new spark plugs didn't help)

but just in case changing the leads doesn't help what else can it be?

btw; the fuel pump is virtually new, and so is the fuel filter.



why are women like clouds? eventually they f**k off and its a really nice day.

telling the truth is just lack of imagination

 Post subject: Re: EL Falcon misses under load
Posted: Fri Aug 29, 2014 11:19 pm 
Getting Side Ways

Posts: 647

Joined: 31st Aug 2007

Gallery: 1 images

Ride: 08 BF Ghia

Location: Melbourne
VIC, Australia

Leads,fuel filter,Injector/s,rotor button,dissy cap, ECU.
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 20 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum



It is currently Thu Oct 27, 2016 12:23 pm All times are UTC + 11 hours



(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names