Fordmods Logo

El falcon noisey lifters on cold start 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: El falcon noisey lifters on cold start
Posted: Fri Feb 17, 2017 7:23 pm 
Oompa Loompa
Offline

Age: 21

Posts: 37

Joined: 7th Aug 2016

Gallery: 1 images

Ride: El Futura Classic

Location: Brisbane
QLD, Australia

started the car this morning to the lovely loud ticking noise, went away within 5 minutes of the car heating up. The cars got has 110k km and when I last serviced it 2 months ago I used 15/40.

I'm servicing it this weekend and wondering if I should stick with 15/40 or go thicker?
Top
 Profile  
 
 
 Post subject: Re: El falcon noisey lifters on cold start
Posted: Sat Feb 18, 2017 11:06 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

MrMitch wrote:
started the car this morning to the lovely loud ticking noise, went away within 5 minutes of the car heating up. The cars got has 110k km and when I last serviced it 2 months ago I used 15/40.

I'm servicing it this weekend and wondering if I should stick with 15/40 or go thicker?


I'm using 10/40 Magnatec in my EL engine and it has done over 150000km since top end rebuild and don't get any ticking. Have you checked your oil level? What is your oil pressure sitting on when the car is running? You might have sticking tappets in the rocker arms...open the rocker cover up and have a look at the rocker arms to see if anything is broken.

You could have sticking tappets or not enough oil is being pumped up at initial start up.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: El falcon noisey lifters on cold start
Posted: Sat Feb 18, 2017 3:47 pm 
Oompa Loompa
Offline
User avatar

Age: 64

Posts: 26

Joined: 16th Jan 2017

Ride: Ford Falcon BA Sedan

Location: Smithfield
NSW, Australia

Put a decent Oil Filter on it, not a ryco or other CHEAPIE brand.
Top
 Profile  
 
 
 Post subject: Re: El falcon noisey lifters on cold start
Posted: Mon Feb 20, 2017 9:11 am 
Fordmods Junkie
Offline
User avatar

Posts: 11739

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Pendaws21 wrote:
Put a decent Oil Filter on it, not a ryco or other CHEAPIE brand.


Been using Ryco for years without issue. Wouldn't buy "home brand" Repco/Supercheap type, but Ryco has never failed me. I believe Ford still sells their Motorcraft one so can always get genuine from them.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: El falcon noisey lifters on cold start
Posted: Mon Feb 20, 2017 12:54 pm 
Oompa Loompa
Offline
User avatar

Age: 64

Posts: 26

Joined: 16th Jan 2017

Ride: Ford Falcon BA Sedan

Location: Smithfield
NSW, Australia

I sold genuine filters for years and I wouldn't touch ryco with a 10ft barge pole.
If you want a GOOD filter, buy a D9AZ 6731A.
Top
 Profile  
 
 
 Post subject: Re: El falcon noisey lifters on cold start
Posted: Mon Feb 20, 2017 3:37 pm 
Getting Side Ways
Offline
User avatar

Age: 45

Posts: 863

Joined: 26th Nov 2007

Gallery: 20 images

Ride: XH Ute / AU3 V8 Wagon

Location: Bris-Vegas
QLD, Australia

I would try a 15w50 oil, and a fresh filter - make sure you fill the filter - and try that.

Does the oil pressure drop off when the engine is warm? When my old XH engine was hot, the oil pressure would drop away on idle, but when I went to a Shell High-Mileage 15w50 it was a lot happier.

 

_________________

Yes, I own a Ute. No, I won't help you move!

EL Wagon Build Thread http://www.fordmods.com/the-garage-f53/sooty72-s-ef-futura-wagon-long-term-project-t90025.html
XH Ute Thread http://www.fordmods.com/post1138970.html#p1138970

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 14 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Thu Dec 14, 2017 6:22 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names