Fordmods Logo

el falcon thermo fans 

 

Page 1 of 1 [ 2 posts ] 

 
 Post subject: el falcon thermo fans
Posted: Wed Dec 13, 2017 5:02 pm 
Fordmods Newbie
Offline

Posts: 2

Joined: 13th Jul 2016

Ride: ford au

Location: perth
WA, Australia

hi all, I have a 1998 el v8, thermo fans not going includeing a/c fan replaced fan relay and 60 amp fuse in fuse box beside the header tank, blew fuse twice, tried 2 sets of fans still not going any suggestions could it be the coolant temp sensor
Top
 Profile  
 
 
 Post subject: Re: el falcon thermo fans
Posted: Sat Dec 23, 2017 10:19 pm 
Technical Contributor
Offline
User avatar

Age: 27

Posts: 416

Joined: 19th Dec 2008

Gallery: 4 images

Ride: AUII XR8 ute

Location: Ballarat
VIC, Australia

If you're blowing fuses straight away, and the other set of fans you tried worked on another car, its an issue from the relay holder to the fan plugs. CTS sends data to ECU, not straight to the fans. And if you're blowing the fuse on the fan relay, then the ecu has already sent out a signal to turn them on.

 

_________________

How many bears could Bear Grylls grill if Bear Grylls could grill bears?

Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 2 posts ] 

Who is online

Users browsing this forum: Google [Bot] and 18 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Mon Jun 25, 2018 3:21 am All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names