Fordmods Logo

EL Falcon won't start 

 

Page 1 of 1 [ 6 posts ] 

 
 Post subject: EL Falcon won't start
Posted: Mon Feb 15, 2016 8:38 am 
Fordmods Newbie
Offline

Age: 63

Posts: 0

Joined: 15th Feb 2016

Ride: EL Falcon

Location: Logan
QLD, Australia

I have an EL Falcon. Sometimes it won't start. Everything on the dashboard works, it all lights up but it won't start until I turn the headlights off and on several times, the battery is fine. It doesn't happen all the time just sometimes. Any ideas?
Top
 Profile  
 
 
 Post subject: Re: EL Falcon won't start
Posted: Mon Feb 15, 2016 10:04 am 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hello,

Does the engine crank over ? Do the dash lights go out ? I would make sure the Battery terminals are tight as a first step.

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: EL Falcon won't start
Posted: Tue Feb 16, 2016 5:43 pm 
Getting Side Ways
Offline

Posts: 959

Joined: 15th Nov 2004

Ride: el wagon

Location: melbourne
VIC, Australia

Quote:
it all lights up but it won't start until I turn the headlights off and on several times,


Man that IS weird...........

Can't offer any suggestions though.........................
Top
 Profile  
 
 
 Post subject: Re: EL Falcon won't start
Posted: Mon Feb 22, 2016 8:14 am 
Fordmods Junkie
Offline
User avatar

Posts: 11640

Joined: 17th May 2005

Gallery: 11 images

Ride: EL Fairmont, VFR400 racer

Power: 144 rwkw

Location: Melbourne
VIC, Australia

Check your battery terminals as mentioned and make sure all EARTH points are good, especially the engine block one.

 

_________________

phongus = Post whore 2006
EL XR6 motor, EL ECU + J3 chip, WADE 1673 Camshaft, 3" S/S intake, Pacy 4480, 2.5" Hi flow cat, 2.5" Lukey exhaust.
Max Power = 144.6 rwkw (03/05/2008)

Top
 Profile  
 
 
 Post subject: Re: EL Falcon won't start
Posted: Mon Feb 22, 2016 8:46 am 
Getting Side Ways
Offline
User avatar

Age: 43

Posts: 3787

Joined: 22nd Apr 2007

Gallery: 5 images

Ride: DENTED UP OLD AUT WAGON

Location: Wellington
New Zealand

Do you get a clicking noise like the relay to starter motor should make, but no starter motor action?

Make sure you have high CCA battery and GOOD connections.

Mine won't start sometimes over and over again, and then starts wonderfully for a week, and then... Well... Thankfully I have manual and ability to crash start
:roll:

Anyhooooo- Change of battery really improved things. Don't know how one of my spares with "European" on the side got in the engine bay on a permanent basis, but never again!
Top
 Profile  
 
 
 Post subject: Re: EL Falcon won't start
Posted: Mon Feb 22, 2016 3:47 pm 
Getting Side Ways
Offline
User avatar

Posts: 2475

Joined: 22nd Jan 2009

Ride: '91 EB Wagoon

Location: Geeelong
VIC, Australia

mine won't start/do anything sometimes when ya go to start it !! :? ... however on mine it's just the ignition switch....... welllll at least that's what i believe :roll: :lol: it will be fixed when me 'new' daily is on the road :mrgreen:
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 35 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Tue Mar 28, 2017 7:07 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names