Fordmods Logo

El Jerking under acceleration 

 

Page 1 of 1 [ 5 posts ] 

 
 Post subject: El Jerking under acceleration
Posted: Thu Nov 13, 2014 8:31 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 16

Joined: 4th May 2011

Ride: Ford Fairmont EF

Location: Nelson
New Zealand

Just brought a EL Fairmont 6 cyl,

After 500-600km of driving the coil died. Have replace with a new one.

Has a slight jerking feeling when you accelerate harder, sure it has this before the coil went.

Had fresh service with air filter, oils.

Will replace spark plugs tomorrow and leads look new (motorcraft)

Any ideas? Fuel pressure? Ive got a new fuel filter for my EF that should fit (if i can get old one off)
Top
 Profile  
 
 
 Post subject: Re: El Jerking under acceleration
Posted: Thu Nov 13, 2014 8:41 pm 
Oompa Loompa
Offline

Posts: 34

Joined: 29th Oct 2014

Location: Launceston
TAS, Australia

Is your timing right? I had a similar problem when I first got my lane which was fixed by setting the timing right and cleaning my injectors. The clean injectors made the biggest difference.
Top
 Profile  
 
 
 Post subject: Re: El Jerking under acceleration
Posted: Thu Nov 13, 2014 8:51 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 16

Joined: 4th May 2011

Ride: Ford Fairmont EF

Location: Nelson
New Zealand

Will check the base timing this weekend, seems to idle fine and normal driving feels good. Just when you over take or put foot down, it has a slight jerk
Top
 Profile  
 
 
 Post subject: Re: El Jerking under acceleration
Posted: Fri Nov 14, 2014 6:44 am 
Getting Side Ways
Offline

Posts: 496

Joined: 14th Sep 2011

Ride: BF II Gas Ute

Location: Canberra
ACT, Australia

Hello,

I had a similar thing, and it was the leads. Not a fun thing to change, and not a 5 minute job. There is a reason a repair shop wants about $100 to do it. I reckon after you did it a few times it would be easier and faster though.

 

_________________

Regards 96ELGli

Top
 Profile  
 
 
 Post subject: Re: El Jerking under acceleration
Posted: Fri Sep 15, 2017 7:07 pm 
Fordmods Newbie
Offline

Age: 26

Posts: 16

Joined: 4th May 2011

Ride: Ford Fairmont EF

Location: Nelson
New Zealand

Thanks for your help, turned out to be the coil breaking down as it died and replaced
Top
 Profile  
 
Display posts from previous:
Sort by  
 Page 1 of 1  [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 35 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

 

 

It is currently Wed Dec 13, 2017 6:56 pm All times are UTC + 11 hours

 

 

(c)2014 Total Web Solutions Australia - Australian Web Hosting and Domain Names